Home / Forums / ePix Support / 1.4 update

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Renzo Palmisano
    Participant

    After installing the 1.4 update with the Envato tool I’ve got this nasty error message:
    Parse error: Syntax error, unexpected T_FUNCTION in …/themes/epix/lib/inc/sub-functions.php on line 161
    Can do almost nothing from the wordpress dashboard! E.g. can’t switch to another theme intermediately or start a restore from my backups.
    Any idea what going on??


    Albrecht Bongartz
    Participant

    Renzo,
    Seems I’m not alone with the issue. I’m relieved that’s probably not me who did something wrong with the theme/update.
    Let’s hope for the best.
    Albrecht


    Paul Guba
    Participant

    Same issue my site is crashed when updated. Nothing loads cannot do anything.

    • This reply was modified 2 years, 10 months ago by  Paul Guba. Reason: get emails

    Paul Guba
    Participant

    You can gain access to your site by FTP and renaming epix theme. WordPress goes to default theme provided you have it installed.

    Andy
    Andy
    Keymaster

    Hi Guys,

    The function used previously is deprecated and therefore I changed it. It would appear that a few hosting companies out there are still using an older version which doesn’t support the new one.

    The best solution so far would be to add the following to your .htaccess file – AddHandler php55-cgi .php via FTP.


    Renzo Palmisano
    Participant

    Hey Andy thanks for that, I went into godady and change my programming language to PHP 5.4. erased the theme from my ftp and installed it again. and it work. Cheers


    Paul Guba
    Participant

    What function are you referring too is it a PHP version? I will ask my host to update.

    Andy
    Andy
    Keymaster

    Yes it’s the PHP version that appears to be the issue. Upgrading will fix it, I’d like to fix it for older versions too. I’ve asked someone for their FTP, if I can get it working for both, I’ll let you know.


    Talia
    Participant

    I’ve just gone to do the update and have come up with the same error message. I now have no access to anything, can’t even get to my WordPress dashboard.

    Above fix hasn’t worked 🙁

    Any update on how to fix this? thanks

    • This reply was modified 2 years, 9 months ago by  Talia.
    Andy
    Andy
    Keymaster

    Hey all,

    I’ve now created a fix here by resorting to the old method. Please replace ePix/lib/inc/sub-functions.php

    with:

    http://help.themeva.com/tmp/epix/sub-functions.php.zip

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.