Home / Forums / You Theme Support / Add a link to a row in the header menu

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts

  • phani36
    Participant

    Hi,

    I have multiple rows on a page for which I want to provide a direct link from the header menu.
    Can you please let us know if that is possible?

    Thanks,
    Phani


    phani36
    Participant

    Hi,

    I was able to add rows to menu using Anchor Link Name.

    For a particular page with sub menus to anchor names, navigation is working from other pages but not within that page itself. How do I fix it?

    Thanks,
    Phani


    phani36
    Participant
    This reply has been marked as private.

    Can you please send over your site’s login credentials so we can personally check and test this?

    Thanks!

    Hi @phani36

    Can you send over your site’s URL and login credentials so we can personally check on this?

    Regards,


    phani36
    Participant
    This reply has been marked as private.

    Hi,

    It looks like the anchor names are not correctly added when I checked. I have added it for ‘One Team’ and if you test the ‘Read More’ button on the page http://192.169.172.117/p/ and also the ‘One Team’ menu item, it should now properly work.

    Can you please check and confirm from your end? If this has fixed your issue, all you need to do is declare the anchor name for each block.

    Thanks!


    phani36
    Participant
    This reply has been marked as private.

    Hi @phani36

    Can we try to disable all plugins on your site, except Visual Composer, just to check if any of them is causing the issue with the anchor links?

    Thanks!


    phani36
    Participant
    This reply has been marked as private.

    I have now fixed the icons and it should now redirect correctly. I changed the link of each icon from the full link to just the anchor and it fixed the issue. It looks like the anchor will not work on the actual page if you specified the full link, that is why I just updated it to just the anchor link.

    This issue will also apply to the menu, that is why it is working from other pages, but if on the actual Products page, the links wont work. The workaround here is to create a new menu copying everything from the current menu. Once done, update the links of the submenu from the full link to just the anchor.

    Once done, all you need to do is go to the Layout tab under the editor here (http://192.169.172.117/wp-admin/post.php?post=5385&action=edit) and set the new menu you created as the Menu for the page.

    Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.