Home / Forums / DynamiX Support / Additional appearing in HTML Source

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Richard Harding
    Participant

    The following HTML code is generated with the DynamiX theme and wpautop filter ON – the default behaviour
    ———————————————————————————————————

    <div class=”ememberbookmarkbutton”>

    <br></br> <<<====================== Incorrect
    <span class=”c”>
    +
    </span>
    <br></br>
    <span class=”t”>
    Bookmark
    </span>
    <br></br> <<<====================== incorrect

    </div>

    ===============================================================================================

    The correct results are obtained
    * with the Dynamix theme enabled and wpautop filter OFF OR
    * with Dynamix Theme Disabled and wpautop filter ON – Default behaviour

    <div class=”ememberbookmarkbutton”>

    <span class=”c”>
    +
    </span>
    <br></br>
    <span class=”t”>
    Bookmark
    </span>

    </div>

    Setting wpautop filter OFF is not a viable solution because paragraphs are no longer displayed.

    Do you have any suggestions?

    Richard Harding


    Tom ( Support)
    Keymaster

    Hi Richard,

    This is a very annoying feature of WordPress that we cannot do much about as ThemeForest are clamping down on developers that modify the wpautop to remove the extra tags WP adds. Is this a plugin that you are using that it is adding extra tags into? Do you have a link to a page it is on if so?

    Kind regards,
    Tom


    Richard Harding
    Participant

    Thanks Tom,

    This is happening with WP emember plugin. I will send you an email with the link and login details so you can see what is happening.

    I have used 2 alternative themes to Dynamix and obtain correct results with standard wpautop behaviour.

    Richard Harding


    Tom ( Support)
    Keymaster

    Hi Richard,

    We do not offer email support, please can you reply to this thread with your details and be sure to set your reply to private so only me and Andy(Theme Creator) can see your reply. We will then look further into this.

    Kind regards,
    Tom


    Richard Harding
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    I will ask Andy about this and come back to you tomorrow morning.

    Kind regards,
    Tom


    Richard Harding
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Richard,

    Extremely sorry for the late reply must have missed this one. Do you have a link to a page with this plugin in question on it so we can take a deeper look into this? Please also provide your login details so we can attempt to fix the issue for you.

    Kind regards,
    Tom


    Richard Harding
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Richard,

    It seems that WordPress is adding in extra br tags to put the alignment out. Try this plugin as it may help you out.

    Kind regards,
    Tom

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.