Home / Forums / DynamiX Support / Are you planning to release another upgrade anytime soon?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Asaf
    Participant
    Hi,

     

    I am asking this because, I am having this theme converted and translated to Hebrew,

    and I know that after translating I will not have the ability to upgrade the theme because of the changes to the files,

    and I will have to stick with that version I had translated – for a very long time….

     

    and that's why I'm asking – should I wait?
    Andy
    Andy
    Keymaster

    Hi,

    What do you require to translate the theme and what version of DynamiX are you using ?


    Asaf
    Participant

    Hey Andy,

     

    First of all, I really want to thank you for your awesome theme and service – Love You – You're Awesome!

     

    I am building a private site for me and my family, and I am using the buddypress plugin with the "DynamiX" theme for this site.

     

    The DynamiX theme is originally in English but we're from Israel, So now I am having the theme converted and translated to Hebrew.

     

    Apart from translating the actual words from English to Hebrew I also need to flip everything from LTR to RTL (left to right – right to left) – all the css and js and images, everything….

     

    I bought the DynamiX theme v2.7.5 on the – 15 of Mar 2011….

    And I thought I could convert & translate the theme myself – but I was wrong – it simply was too difficult for me – I have no knowledge in technical stuff like these and I just messed things up…. 

    So, on the 23 of May 2011 I finally found someone that can convert & translate my theme for me, and I hired him, and I gave him the theme I had, and he started working on it ……

    But……after he did most of the translating job I noticed that many things didn't work properly, specially the galleries! – And that's when I noticed that the version I gave him was v2.7.5!!! (Because I didn’t know you've released an upgrade to v2.8.1 – which I actually found out after coming to this forum searching for solutions to the galleries not working )

    So, I downloaded the 2.8.1 version and gave it to my guy to start the converting & translating job all over again – on that version! (I had to pay him more for that…)

    And now, I just found out again that there is another upgrade available – v2.8.2, and there are some bug fixed on that version….

    So once again, after my guy did most of the translating job on the 2.8.1 version – I asked him if he wouldn't mind doing it all over again for the current upgraded 2.8.2 version!!!???

    He got very irritated with me (and I can understand why….) and he said he will need more money if his going to do this job all over again….

    And that's what I am asking – what should I do ?

    I am afraid if I'll add more money this time and give him to translate v2.8.2 – you'll be releasing another upgrade with more bug fixes and awesome options……

    I'm very puzzled?!?!?!

    Is it OK for me to have him convert & translate this 2.8.2 version – or – you're planning another upgrade soon ?

    After the conversion & translation to Hebrew – I know will not have the ability to upgrade for a long time (because I can't just upload and run over all the old files with the new files like if I had it in the English version – I will have to convert & translate the new version as well – and it costs a lot of money )

    I don't want to be stuck with a buggy version for a long time!

    What do you suggest I should do Andy?


    Asaf
    Participant

    I sent you my site URL via PM…..

    Andy
    Andy
    Keymaster

    Hi Asaf,

    The translation has changed in 2.8.2 – it now uses different files and are not affected when upgrading. The only thing left is the RTL changes – if you could somehow get that CSS off him I'll happily make the theme RTL compatible (when I have time) for future and so your headache of upgrading will be over. 😉

    Andy
    Andy
    Keymaster

    Oh and thank you for the praise, it's greatly appreciated!! 

    Andy


    Asaf
    Participant

    Hey Andy,

    Thank you so much for your assistance – I truly appreciate it!

    Yea..…about the translation, I've noticed you’ve implemented in this new v2.8.2 the – Po. Mo. Files – it's awesome – you don't know how happy you’ve made me just for doing that!

     

    And about – making the theme RTL compatible – WOW!!! It would be so great if you'll be able to do that for all of us RTL people – I hardly can wait!!!

    But what did you mean when you’ve said – "if you could somehow get that CSS off him"

    Did you mean that you want me to give you the CSS files – after we finish converting it to RTL?

    If that's what you’ve meant, then my friend – I'll be more than happy to give you all…. the files…….after we finish the job!!!   

    Especially if that would help you make the theme RTL compatible – future upgrading is one of my biggest fears. (e.g. – not being able to upgrade…). 

    Again, Thank you so much for your advice and assistance my friend 🙂

    Have a great week.

    Asaf

    Andy
    Andy
    Keymaster

    Hi Asaf,

    Yes if you could send me over the files after you've converted it, that would be great – I can compare CSS and create a separate CSS for RTL users only. That way you won't have to worry about upgrades 😉 

    Even better if you got them to create or list the changes they make. I'll add the functionality to the functions.php file to load in the separate CSS file when RTL is used. 

    Thanks

    Andy

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.