Home / Forums / DynamiX Support / Assigning the return value of new by reference is deprecated

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Steven Ready
    Participant

    Troubleshooting a site that had the dreaded WordPress Blank screen (of death) showing and I put

    error_reporting(E_ALL); ini_set(‘display_errors’, 1);
    define( ‘WP_DEBUG’, true);

    to show errors. I’m getting this one which makes reference to the envato-wordpress-toolkit-master. Do you know what this is saying and any idea on how I can fix it?

    Deprecated: Assigning the return value of new by reference is deprecated in /var/www/vhosts/mywebsitename.com/httpdocs/wp-content/plugins/envato-wordpress-toolkit-master/index.php on line 207 Notice: Undefined index: post_type in /var/www/vhosts/mywebsitename.com/httpdocs/wp-content/plugins/filter-pages-by-parent-in-admin/filter-pages-by-parent-in-admin.php on line 81 Notice: Undefined index: skin_id_frame_header in /var/www/vhosts/mywebsitename.com/httpdocs/wp-content/themes/DynamiX/header.php on line 89 Notice: Undefined index: skin_id_frame_footer in /var/www/vhosts/mywebsitename.com/httpdocs/wp-content/themes/DynamiX/header.php on line 91

    (name changed to mywebsitename.com for privacy)

    As part of my troubleshooting I have updated to the latest WP version 4.2.1 and the latest DynamicX theme 4.2.4

    Thanks

    • This topic was modified 2 years, 7 months ago by  Steven Ready.
    Andy
    Andy
    Keymaster

    Hi Steven,

    The usual cause for the “white screen of death” is WordPress memory. Have you increased this value, you can follow the WP guide here if you’ve not.

    https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    The warnings above are due to a number of things, one is the theme and two of them are plugins. But they’re just warnings and wouldn’t cause it.

    If you’re using Advanced Excerpt, I’d recommend disabling this plugin. It appears to be very memory hungry and has caused a few issues over the past few months. I’ve stopped recommending it.


    Steven Ready
    Participant
    This reply has been marked as private.

    Steven Ready
    Participant

    Oh and I increased the memory (thank you for the link).

    I forgot to mention, all the sidebars/widgets have disappeared from the page too 🙁

    Andy
    Andy
    Keymaster

    Hi Steven,

    The warnings above suggest that WP_DEBUG is still enabled, you can disable this and the errors will not display. They’re not important, however I’ll make note of them to resolve.

    As for the widgets disappearing, this usually happens when the Theme has been changed, maybe you uploaded a different folder name or something. When that happens, WP thinks it’s a new theme and resets the sidebars. Luckily they’re all still there, just within the “inactive widgets” section in Appearance > Widgets.

    Has the white screen issue disappeared now?


    Steven Ready
    Participant

    Thanks for the tip on where to find the widgets. I hadn’t checked “inactive widgets”, they’re all back in place now.

    At the moment the white screen issue is resolved, but like I said last time it was “fixed” it went back to the white screen within a day or so. I’m not sure if the issue is fixed properly or just temporarily.

    Hopefully using 4.2.2, getting rid of Advanced Excerpt and increasing the memory has got it resolved properly. Time will tell I guess.

    Thanks for your assistance.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.