Home / Forums / DynamiX Support / Author Name shows up? 2.8.9

Viewing 15 posts - 1 through 15 (of 42 total)
  • Author
    Posts

  • Kyle Fleming
    Participant

    Author Name shows up?

     

    How do I remove the author name it says “By: ________”  I don’t want it to say this. This may be a WordPress formatting issue and not with DynamiX but can’t see where in the settings I can remove this.  This not on my /blog page but on every other page where I have text.

    http://www.kyleflemingphotography.com

    Thanks,

    Kyle

    Andy
    Andy
    Keymaster

    Hi Kyle,

    Annoyingly I've missed a simple condition which permanently shows the Bio. You should be able to disable it from the Blog Settings admin page. 

    However as you know it doesn't. You'll need to implement this quick fix. 

    Edit DynamiX/single.php

    Search for  <?php if($DYN_authorname) { ?>

    And replace with 

     <?php if($DYN_authorname!='disable') { ?>

    I'll sticky this topic for others. 


    Kyle Fleming
    Participant

    Thanks Andy,

    I found the single.php file and changed the <?php if($DYN_authorname) { ?> to <?php if($DYN_authorname!='disable') { ?>

    It still shows the "by".  I hit refresh, but it is still there.

    Kyle


    Scott C
    Participant

    try holding down CTRL when you press F5 to refresh. Likely it's just showing you the cached version of the page.


    Kyle Fleming
    Participant

    I tried the site on a different computer and the changes to the single.php file did not change the issue.

    http://www.kyleflemingphotography.com

    Any other ideas?

    Thanks,

    Kyle

    Andy
    Andy
    Keymaster

    Hi Kyle,

    Have you made sure the option is set to disable within DynamiX -> Blog Settings?


    Kyle Fleming
    Participant

    Thanks Andy,

    It was already set to disable in the Blog settings.  But this does not happen on "blog" page but on my other ones.

     

     

      
    Andy
    Andy
    Keymaster

    Hi Kyle,

    Is that on a page?

    In which case try editing DynamiX/page.php

    Search for <?php if($DYN_authorname) { ?>

    Replace with 

    <?php if($DYN_authorname!='disable') { ?>

    Let me know how that goes. 

    PS. Clearly updating the Theme around my Birthday celebrations was not a good idea!


    Kyle Fleming
    Participant

    Andy thanks for all your help…. but that still didn't resole the issue.

    It is actually on the main/home page only. Not on any other pages, nor on the blog. 

    Kyle

    Andy
    Andy
    Keymaster

    Hi Kyle,

    Is it just a normal page you're using for the homepage? 


    Kyle Fleming
    Participant

    Yeah, my homepage is a normal page. It is actually my "about me" page. My blogs post to my blog page.

    None of the other pages have the author text showing.

    Andy
    Andy
    Keymaster

    Hi Kyle,

    Can you send me your login and I'll try to see where it's failing – I've tested on my server and can't replicate the issue. 

     

    Thanks


    Fernando
    Participant

    Hello Andy, I´m having that exact issue :S

    all my pages for some weird reason are now shoring by:____

    I will try your solution and if it doesnt work can I give you my login info too?


    Fernando
    Participant

    hello, so by editing the page.php and blog.php I was able to get rid of the By but now there's a double line showing, which is really weird…how can we get rid off that too?

    I cant show u the page since it is on an internal domain for my company but this is what it looks like: http://www.flickr.com/photos/fcastroa/6902312220/ the home page and on a child page http://www.flickr.com/photos/fcastroa/6902312178/in/photostream/ 


    Kyle Fleming
    Participant

    Andy,

    Thanks – I PMd a username/password I created for you.

    Kyle

Viewing 15 posts - 1 through 15 (of 42 total)

You must be logged in to reply to this topic.