Home / Forums / DynamiX Support / Author not showing on archive pages

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Craig Courtney
    Participant

    On my site I want all posts to show there author, but I don’t want author to show up under page titles. In my theme options I have “Show Author Bio” set to Posts.

    When I’m viewing a single post the author shows up properly in the post meta line, unfortunatley on my primary blog page and archive pages the post meta line does not show the author.

    If I set “Show Author Bio” to Posts & Pages the main blog page and the archives properly show the Author in the bio, but this also puts a “by author” line under each page title which I do not want.


    Tom ( Support)
    Keymaster

    Hi Craig,

    So you want the author meta data to show but you don’t want to have the link ‘by author’? Do you have some URL examples of this so I can get a better understanding of what you mean and your set up?

    Kind regards,
    Tom


    Craig Courtney
    Participant

    I’ll work on getting some screens or a log-in setup, in the mean time here are the steps to recreate.

    Setup

    1. Create a new site with two pages (Home, Blog and Products). Put dummy text in home page.
    2. Create three posts with dummy content
    3. Setup theme to use Home for static home page and Blog for posts page.
    4. Setup theme options Blog -> Display Post Metadata -> Archive / Single Post
    5. Setup theme options Blog -> Post Metadata Align -> Below Title

    Scenario One

    1. Setup theme options General -> Show Author Bio -> Posts & Pages
    2. If you go to home you should get a page with a Title of Home with content below the title. There is a “by Author” line directly below title.
    3. Go to blog page. Each blog entry has a title with a meta line below it. There is an author in each meta line, which is correct
    4. Click on blog entry which takes you to single post view. Author is shown on meta line with date.

    Scenario Two (Desired, but bug on step 3)

    1. Setup theme options General -> Show Author Bio -> Posts
    2. If you go to home you should get a page with a Title of Home with content below the title. There is no “by Author” line directly below title.
    3. Go to blog page. Each blog entry has a title with a meta line below it. There is not an author in each meta line, which is incorrect
    4. Click on blog entry which takes you to single post view. Author is shown on meta line with date.

    Scenario two can be replicated on any archive or multi-post page.


    Tom ( Support)
    Keymaster

    Hi Craig,

    I have spotted something which may be the problem for everything here.

    When creating a blog page, you will need to set your page as a Blog Template. Edit the page > Find page template on the right > Select Blog > Save.
    Do not set the Blog page within Settings > Reading > Posts as this is the default way of setting a post page by WordPress and will conflict with the template.

    Please try this out as it may solve a few of your problems.

    This will also be added to the documentation.

    I await the other details.

    Hope this helps.

    Kind regards,
    Tom


    Craig Courtney
    Participant

    Unfortunately that did not fix it for me. I went into the Settings > Reading > Posts and deselected the posts page. It now says –Select– in the drop down for posts page.

    My blogs page was already set to the Blog page template. I change it to Gird Blog and back to Blog but neither changed how it was rendering the post meta line.


    Tom ( Support)
    Keymaster

    Hi Craig,

    Ok not to worry was just an idea. I wait the other details from you and I will look into this further.

    Kind regards,
    Tom

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.