Home / Forums / DynamiX Support / Author Not Showing on Posts

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Brian Knapp
    Participant

    I am having problems getting the appropriate metadata to display. I have “Static Front Page” set to “Your latest posts” under Appearance…Customize. In Appearance…Theme Options…Blog I have “Display Post Metadata” set to “Single Post Only”. I am also using the grid layout format with two columns.

    No metadata appears at all on any posts, neither on the main page or when you click the post title to read it. If I change “Display Post Metadata” to “Archive/Single Post”, then and only then does any metadata appear. Problem is, the post author is not one of the items that appears.

    What I would like to do is show the post author and date on the main page and also in any post when I click on the post title.

    Thanks –

    Brian


    Tom ( Support)
    Keymaster

    Hi Brian,

    My recommendation for creating a blog page as your home page is to do the following.

    Create a new page, Home or whatever,
    Change the page template to Grid Blog within the settings on the right hand column
    Save and preview,
    Go to Appearance > Settings > Reading > Unselect anything under Posts page and set your new home page as the static page.

    This should then make your home page a properly set out grid blog template and have everything else correctly set up.

    If you are still having issues, please set your reply to private and provide your URL/login details so I can take a further look for you.

    Kind regards,
    Tom


    Brian Knapp
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Brian,

    So if I am understanding you correctly, you want to have the home page set to a Blog template right?

    Or do you want to have the home page like it is and have a /blog page with your blog posts? Once I understand this, I can set this up for you.

    Kind regards,
    Tom


    Brian Knapp
    Participant

    Hey Tom – the site is primarily a blog, so that’s what I want to show up when a person first loads the site. Whether I set the initial page to “latest posts” or a static page that is a blog template doesn’t matter so much to me. What matters is that the blog is the first thing that loads when someone comes to the site.

    Thanks!


    Tom ( Support)
    Keymaster

    Hi Brian,

    Ah ok, I see how you want things set up now. You were basically there with the set up, just the Display Post Metadata was set to Post only so no author info was shown on the blog and the Show Author Bio was set to disable too.

    If you update to the latest version of DynamiX, the author info will show on one line instead of two as there was a small bug with the previous version.

    Kind regards,
    Tom

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.