Home / Forums / DynamiX Support / Avatar not appearing on Buddypress pages

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • MaP
    Participant

    I uploaded avatars on through the WordPress User Profile screen and any “WordPress” page shows the Avatar including the toolbar on the top right. However, on all the Buddypress pages, the Avatar is not showing (just the generic gray man avatar). Any suggestions to resolve this issue? Do I need a buddypress plugin to pass the WordPress Avatar to Buddypress? Thank you.


    Tom ( Support)
    Keymaster

    Hi,

    When you login and have your avatar set as something else, does the grey avatar change on each page or still stay the same?

    Kind regards,
    Tom


    MaP
    Participant

    Here is an example: http://student.lecomsga.com/members/
    The widget (wordpress feature) on the right for login has the Avatar displayed correctly, but in the members directory of Buddypress still shows the gray generic avatar. This occurs on any member and its not isolated to one specific member profile/avatar. As another example, your photo and my purple photo (above) are not being displayed throughout the buddypress side of my website.


    Tom ( Support)
    Keymaster

    Hi,

    I would recommend de-activating that plugin as the normal way to change your avatar is through Buddypress, but it does not seem to have the standard options as we do on this forum for example.

    Please let me know if that resolves it.

    Kind regards,
    Tom


    MaP
    Participant

    I deactivated the plugin but I do not know where on my site or Buddypress pages I can upload an avatar? Is a settings criteria messed up?


    Tom ( Support)
    Keymaster

    Hi,

    Do you have the latest version of Buddypress installed? Also, do you have Extended Profiles ticked under Settings > Buddypress > Components > Extended Menus?

    Kind regards,
    Tom


    MaP
    Participant

    My fault. Yes the Extended Profile somehow got unchecked. I activated it and it all works. Thank you for your help! This topic is resolved.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.