Home / Forums / DynamiX Support / Blog Not Displaying Properly

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts

  • Jason
    Participant

    Hi Andy,

    I’ve reactivated Envato, updated the theme and everything appears to be working except for one issue. The majority of my site’s ‘blog’ layout pages are grids with featured images. However one page in particular is a normal blog layout showing quick posts featuring a lot of video embeds.

    Since the update, I got an error dialogue saying Visual Composer needed to be updated to ensure maximum compatibility. I haven’t received a notification for that update so I dismissed the message. Now any page with a blog layout only shows the title if a video is used.

    I’ll include my site details in a private post.

    Thanks again,
    Jason


    Jason
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Jason,

    This is really interesting. It should automatically pull an excerpt from the post. It’s using a standard WordPress method now and there maybe a bug.

    I’m going to have to do some testing on my server to see if I can replicate it.

    Leave it with me.

    Andy
    Andy
    Keymaster

    PS. Great looking site, congrats!


    Jason
    Participant

    Thank you very much! Looking forward to launch. Any luck finding the issue behind this bug?

    Andy
    Andy
    Keymaster

    Hi,

    It looks like there is bug with the WordPress excerpt engine.

    The only way around this is to add an excerpt via Post > Excerpt. I’ve added one this post here: http://www.nerdinfinite.com/the-dc-cinematic-universe-wins-comic-con-2015/


    Jason
    Participant

    Thanks. I saw the excerpt but unfortunately I really need the videos to appear. The majority of the posts on this page feature videos. September alone will spotlight 30 short films. Adding an extra click is to see them won’t be ideal. It’s especially weird because images show up just fine and the post reacts normally.


    Jason
    Participant

    My issue is I need it set to excerpt as the majority of my pages are grid layouts. But this one page needs to display full posts with a blog layout but the ‘post content’ setting in Theme Options is universal. Is it possible to set post content to ‘excerpt’ on grid blog and ‘full post’ for regular blog template?

    Andy
    Andy
    Keymaster

    Hi Jason,

    The only way I’ve found to do it is to use the “Advanced Excerpt” plugin. This will allow YouTube videos.


    Jason
    Participant

    Thanks. It took some customizing but the site is working how I had hoped thanks to the plugin! I appreciate the help!

    Andy
    Andy
    Keymaster

    You’re welcome 🙂

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.