Home / Forums / DynamiX Support / Blog page issues

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts

  • The Denovati Group
    Participant

    Hi Andy. We have several issues with the “recent posts” element on http://arts-festival.com/blog:

    1. When we use image+text, the formatting is wonky (there’s a lot of extra space) when the image has a caption.
    2. To help alleviate that, we disabled the date, but as you can see it’s still appearing.
    3. The first page of posts is fine, but if we try to advance to the second it goes to this post: http://arts-festival.com/2010/07/2010-arts-festival-award-winners-announced/. That happens both when we click on page 2 and when we click on the forward arrow.
    4. I tried limiting the posts to 5 to see if that fixed the pagination issue, but as you can see >5 posts are listed and the forwarding still doesn’t work.
    5. If you try to click on a different page (3 through 9), you get a 404 error.
    6. Basically, no matter what we try to change, the page seems to have a mind of its own in terms of how it functions. And it’s a little frustrating to have to update the page to have any of the changes we try to make appear. If we just preview the page, it displays Home.

      What can we do to fix this and make the page fully functional again? Everything is current and there’s no indication this is a deprecated element…

      Thanks!

      Courtney

    Andy
    Andy
    Keymaster

    Hi Courtney,

    1. Do you mean below the “Caption Text”, if so, please try adding this bit of CSS to Appearance > Theme Options > Customize > Custom CSS:

    .wp-caption {padding:5px 10px !important;}

    2. To disable that date, it’s via the Appearance > Theme Options > Blog > Metadata > Disable

    3. Can you provide your WP login details please, I’ll need to see what maybe causing that. It’s worth checking to see you do not have a “Posts Page” set in Settings > Reading.

    4,5, something is amiss, that’s not standard behaviour. It could be a plugin causing that, so please try disabling them all to see if that resolves it.

    Failing that, please post your WP login details and I’ll take a look for you.


    The Denovati Group
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Courtney,

    The login details do not appear to work?

    It is best to use the Blog template instead of the Recent Posts, having said that – there shouldn’t be any issues with doing that either.

    Which page is your blog page?


    The Denovati Group
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Courtney,

    I’ve disabled the date for Archive and just set for posts only, does that make it any better?


    The Denovati Group
    Participant

    Hi Andy.

    I’ve asked the client what they think of the new format. It’s definitely cleaner…. I notice that the heading/title still isn’t showing up, and the pagination is still wonky. Any thoughts on that?

    Courtney

    Andy
    Andy
    Keymaster

    Hi Courtney,

    It appears that the plugin “custom permalinks” is causing the issue. It’s done something to upset the permalink structure and when clicking on “Page 2” it’s changing the structure and will not land on the second page.

    I recommend disabling this plugin and resetting your permalink structure.


    The Denovati Group
    Participant

    Sorry, Andy, I’m not sure I have enough know-how to do that (i.e., disable this plugin and reset the permalink structure) with confidence. I believe we have used custom permalinks on every page of the site (which number over 300). What would happen to them if I disabled this plugin? I’d hate to break 99+% of the site to solve an issue on one relatively unimportant page. Perhaps we should just get rid of the pagination altogether and only present the latest posts. People can the access older posts via the categories, which seem to be working fine.

    I’ll try to have another look tomorrow and get back to you with a final response. If I don’t do it tomorrow, it won’t be until next week as I’m leaving town for a few days.

    Thanks for all your help.

    Courtney

    Andy
    Andy
    Keymaster

    Hi Courtney,

    I’m not sure what would happen if the plugin is disabled. I’m guessing if you’ve applied it to every page, it will cause some issues.

    What’s the reason for using that plugin?


    The Denovati Group
    Participant

    Hi Andy.

    Someone else set up that plugin when we redid the website in 2014, but I believe we use it on every page and post to craft the urls. I’m not exactly sure what would happen if we disabled it – and I don’t think I want to find out!

    FWIW, we use that same plugin with your theme on the Denovati website, and we have no issues with using the Recent Posts element. Here are some examples:

    http://denovati.com/smart-resources/social-digital-engagement

    http://denovati.com/smart-articles

    I think the problem is rooted in the fact that we’ve specified a blog page on arts-festival.com, and that’s what’s the causing the conflicts. I just turned that off and tweaked a few things in the element and it looks much better! I’ll work with the client now to determine which format they want to use.

    Thanks again for your help!

    Courtney

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.