Home / Forums / DynamiX Support / Blog Page very slow

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts

  • SeraLu
    Participant

    I’ve created a blog page with grid-gallery (Visual Composer), but it takes so much time to open the site. Too much time. Some friends tested and it takes from 4 seconds up to 14 seconds. What could cause the problem?

    Hi @seralu

    Can you send over your site’s URL and login credentials so we can check it further?

    By the way, what’s the current version of your theme and Visual Composer?

    Regards,


    SeraLu
    Participant
    This reply has been marked as private.

    Hi,

    As I checked, you are actually loading at least 60 posts (excerpt + image) on the page and this is definitely causing the lag on the load time.

    The best option would be to lower the number of posts to show per page so that the stress on your hosting server will be lesser.

    You will see the result of the test I did here: https://tools.pingdom.com/#!/eip55h/http://www.alexandraschatz.de/blog

    You will see that majority of the load time is spent on ‘waiting’ for the server to respond. Reducing the posts you are showing on the page, should also lessen the wait time.

    Also, adding a caching plugin to your installation should help on speeding up the site.

    Regards,


    SeraLu
    Participant

    Thanks for your reply. It does not work to reduce the posts, I’ve set the limit to 15 and it shows all. I dont know how to limit the posts. Can you take a look? Thank you 🙂


    SeraLu
    Participant

    oh, and which caching plugin should I use?

    Hi,

    I tried to check but it looks like Visual Composer is not working correctly on the site, Can you please give us permission to disable all your plugins so we can check if any of them is breaking VC?

    For caching, as I checked, you are already using WP Super Cache. W3TC and WP Rocket are great options too.

    Regardsm


    SeraLu
    Participant

    Yes, I got WP Super Cache yesterday 🙂

    Please do so, deactivate the plugins, but please dont forget to activate them again 😉

    I have disabled all your plugin and VC still won’t work properly. There seems to be an issue with the site/server, possible memory leak, because if we try to disable at once, the site runs into an error so we had to do it one by one.

    Can you please coordinate with your hosting provider and ask what is your current PHP Memory? If possible, can you please increase it to 128MB?

    Thanks!


    SeraLu
    Participant

    I’ve set it to 96 mb as this is the max possible with my hosting package. If this is not enough I have to upgrade the package (and need to know, if this will fix the problem 😉 )

    The increase on PHP memory has really helped as Visual Composer has now worked. Stretching it out further to 128MB would be better. Can you please check if your Blog page is loading better now? Also, it looks like WP Super does not work well for you site as there is an error if I try to clear cache.

    Thanks!


    SeraLu
    Participant

    I’ve set the post limit to 9, but it still shows all posts. I don’t think it loads faster. What was the problem with VC? What did not have worked?

    The server was running out PHP causing VC not to properly work. When you increased PHP memory, it gave VC more wiggle room to operate.

    For the grid, the issue seems to be from the Custom Grid Template you created. I tried setting it to Masonry Grid: Default and the grid only loaded 9 items, with the Load More button. You can personally try it as well.

    Thanks!


    SeraLu
    Participant

    No, I’ve created the custom grid yesterday and it works like a charm. I’ve used the gallery grid before (this one with the “t” as logo), as this was the only style I liked 😉 then I’ve found the custom thing…

    Just to confirm, is everything all set on your blog page now?

Viewing 15 posts - 1 through 15 (of 26 total)

You must be logged in to reply to this topic.