Home / Forums / You Theme Support / Blog template shows posts from both languages

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts

  • eng_aymanaly
    Participant

    Hi Team,

    I created a page and set its template to “Blog” and now my English blog page shows Arabic and English posts.


    eng_aymanaly
    Participant

    Also in the navigation menu, I want to change the language switcher

    Hi @eng_aymanaly

    Can you send over your site’s URL and login credentials so we can check on this further?

    Thanks!


    eng_aymanaly
    Participant
    This reply has been marked as private.

    Hi @eng_aymanaly

    You actually have the Arabic posts as one of your posts as seen here: http://l-dev.website/karim-kamel/wp-admin/edit.php

    If you do not want it to appear on the blog page, all you need to do is to delete it.

    For the language switcher, what do you want to change with it? Please specify and elaborate.

    Regards,


    eng_aymanaly
    Participant

    I want to have the Arabic posts appear on the Arabic blog and English posts appear on English blog.

    Also as you can see in the Arabic home page, the content for each slide is floated to the right and not centered like the English version
    Check the image below
    http://puu.sh/p3xIr/e94c93dcde.jpg

    Hi,

    If you will check, one Arabic Post actually appears on English as seen here:
    http://l-dev.website/karim-kamel/wp-admin/edit.php?post_type=post&lang=en

    Then one post in Arabic.
    http://l-dev.website/karim-kamel/wp-admin/edit.php?post_type=post&lang=ar

    All you need to do is move the post to ‘Arabic’ and that should not appear on ‘English’ anymore.

    For the text’s alignment, Arabic is actually set as an ‘RTL’ language, that is why it’s laid out right-to-left. If you want to laid out center, a CSS must be applied to it to overwrite RTL.

    Regards,


    eng_aymanaly
    Participant

    Thanks it solved the Blog issue for me.

    What element do I need to apply the center alignment to? just tell me the its CSS class or ID

    On the post editor, edit the content’s HTML and you should see this:
    <p style="direction: rtl;text-align: justify;">

    Just change the value of direction to ltr from rtl. I actually removed it from the first paragraph of the first file.

    To add, you can use this CSS:

    .rtl{
    direction: ltr;
    }

    Regards,


    eng_aymanaly
    Participant

    Thanks for that. I want to know how can I change the icon for the language switcher? It shows font awesome flag which I do not think will be understood by many. I want to have the language on the outside without clicking on the flag icon or at least change the flag icon to show the other available language.


    eng_aymanaly
    Participant

    Also I’ve discovered that in any post in both languages, at the bottom, there is a text saying “Share This Post”. When I click on any of the icons below it, it does not share the post. Instead it opens the profiles which I entered in the “Social” setting in the theme options.

    And in the Arabic posts, the comments section is not the same as the English. The fields a user has to fill to comment are different in the Arabic from the English.

    Hi @eng_aymanaly

    For the language switcher, you can set it here: http://l-dev.website/karim-kamel/wp-admin/admin.php?page=sitepress-multilingual-cms%2Fmenu%2Flanguages.php under ‘Language switcher options’

    Just select the Language switcher widget, on your case ‘Header Panel’ then select ‘Language switcher style’ to ‘Drop-down menu’.

    For the comments section, both Arabic and English comment section are actually asking the same details. Please elaborate on the issue.

    For Social Icons sharing to work, you must use these URLs:
    Facebook: http://www.facebook.com/sharer.php?u=%5Bget_permalink%5D&t=%5Bget_the_title%5D&popup=yes
    Twitter: http://twitter.com/share?text=%5Bget_the_title%5D&url=%5Bget_permalink%5D&popup=yes
    Google: https://plus.google.com/share?url=%5Bget_permalink%5D&popup=yes

    Regards,


    eng_aymanaly
    Participant

    Where would I place those Social sharing links ??

    Hi,

    Please login to your WordPress Dashboard then go to ‘Appearance’ > ‘Theme Options ‘ > ‘Social Media’

    Regards,


    eng_aymanaly
    Participant

    Well I want to add FB and Twitter pages as well as having sharing buttons on posts. What you are suggesting will only show the sharing buttons.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.