Home / Forums / DynamiX Support / buddypress problems

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • alen wang
    Participant

    Hi andy,

    After using buddypess,contents are overlapping the kinds of bars such as sidebar.

    http://chinasweaterbase.com/groups-2/i-ching/forum/topic/test/

    Below “Forum directory” &Above “viewing post 1 to 1” area,there are some part invisible.

    http://chinasweaterbase.com/forums-3/

    Below “Alll Topics” &Above “viewing post 1 to 1” area,there are some part invisible.

     

    There are many places like this,there are problems with the modules or  templates.

    Then i used BuddyPress Template Pack plugin,as it said,i didn’t finish setting,requires change header.phpsidebar.php and footer.php

    It is still hard for me after reading the instruction.

     

    But until now,i don’t have a buddypress forum.

    please help.

    Andy
    Andy
    Keymaster

    Hi Alen,

     

    Something is definitely conflicting, you don’t need the BP Template Pack Plugin, it will work without that. What forum type are you using?

     


    alen wang
    Participant

    Hi andy,

    Thanks,you are right,there is a plugin conflicting with the theme.

    In this site,which plugin do you use for the reply TinyMCE?

    Users can’t upload photos when posting or replying.

    this site http://nurburgringdrivers.com/ how to make the effect of the left bottom Users photos gallery?

    Andy
    Andy
    Keymaster

    Hi Alen,

     

    I use this plugin:

     

    http://wordpress.org/extend/plugins/u-buddypress-forum-editor/

     

    As for the users – I believe that’s just the members widget.


    alen wang
    Participant

    Hi andy,

    Thanks for your help

    i has added the plugin u-buddypress-forum-editor

    And enabled the default setting,but nothing has happened.

    http://chinasweaterbase.com/groups-2/i-ching/forum/topic/test/

     

    I refered the related plugin comments,there is the same problem for other users,but no reply to fix it from author.

    Do you have any advice?

     

    And how to make the topic fixed on the forum’s first topic like

    Theme Customisations Screencast

    Andy
    Andy
    Keymaster

    Hi Alen,

     

    I think I had to change the Theme in BuddyPress -> U Forum Editor to default and it worked.


    alen wang
    Participant

    Hi andy,

    Thanks for your helps.There is another problem.

    The post and topic time&date is very important for my site.The default buddypress doesn’t display the post&topic date&time.And in BP forum,it is advised to replace the <?php the_time() ?> in BP default index.php with <p>Posted: <?php the_time(‘F j, Y’); ?> at <?php the_time(‘g:i a’); ?></p> ,but for this theme,the bp default codes have been changed,i tried it but failed.Please where should the codes of

     <p>Posted: <?php the_time(‘F j, Y’); ?> at <?php the_time(‘g:i a’); ?></p> be insert to show the time&date?
    Andy
    Andy
    Keymaster

    Hi Alen,

     

    Can you provide a link to the page where you need this changed and I’ll give you the page where to change it.


    alen wang
    Participant

    Hi andy,

    i.g.in this site,”alen wang said 1 day, 21 hours ago:”

    just change the “1 day,21 hours ago”to specific time&date of “4:28 pm,Dec 3,2012” I want all topics&reply’s time in group forums to be changed.

    The forum type i use is group forums like this site.It is better to change all the time show to specific time.

    http://chinasweaterbase.com/groups-2/i-ching/forum/topic/test/

     

    regards

    Andy
    Andy
    Keymaster

    Hi Alen,

     

    This has actually been set by BuddyPress – you’ll find the file here:

     

    DynamiX/groups/single/forum/topic.php

     

    This is the line:

     

    <?php echo sprintf( __( '%1$s said %2$s:', 'buddypress' ), bp_get_the_topic_post_poster_name(), bp_get_the_topic_post_time_since() ); ?>


    alen wang
    Participant

    Hi andy,

    Thanks,I replaced

    <?php echo sprintf( __( ‘%1$s said %2$s:’, ‘buddypress’ ), bp_get_the_topic_post_poster_name(), bp_get_the_topic_post_time_since() ); ?>

    with

    <?php date_default_timezone_set(“PRC”);echo $showtime=date(“m-d-Y g:i:s a”);?>

     

    It worked.

    This is the topic time display,and where to display the Reply time&date?

    And I changed it in the default BP template,but how to change them at the functions-buddypress.php in DynamiX Child Theme.

    I appended the below codes in the functions-buddypress.php,but failed,i amn’t familiar with the codes

     

    function time_display() {
     <?php date_default_timezone_set(“PRC”);echo $showtime=date(“m-d-Y g:i:s a”);?> ;
    }
    add_action( ‘topic’, ‘time_display’ );

     

    Could you tell me the codes together with the Reply time&date display codes in the functions-buddypress.php?

    This is the last problem for my site.

     

    Regards

    Andy
    Andy
    Keymaster

    Hi Alen,

     

    I’m not sure how this is changed, is there any reason why you can use control the data/time via WP -> Settings -> General -> Time? Or do you need it separate for BP only?


    alen wang
    Participant

    Hi andy,

    The problem has been fixed,just replace

    <?php echo sprintf( __( ‘%1$s said %2$s:’, ‘buddypress’ ), bp_get_the_topic_post_poster_name(), bp_get_the_topic_post_time_since() ); ?> ?you mentioned)

    with

    <?php echo bp_get_the_topic_post_poster_name(); ?> <?php global $topic_template;date_default_timezone_set(“PRC”); echo date(“m-d-Y g:i:s a”,strtotime

    ($topic_template->post->post_time)+8*60*60); ?>

     

    But I did this in the topic.php,how to do it the function-buddypress.php(BP child theme)?Could you tell me the codes?

     

     

    Regards


    Tom ( Support)
    Keymaster

    Hi Alen,

     

    I would recommend asking on the Buddypress forums about this question as they would probably know the hook for it.

     

    Thanks,

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.