Home / Forums / DynamiX Support / Bug: Visual Composer images not working on clean install

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • Joe Regan
    Participant

    I have found this to be reproducible.

    Clean install of latest version of wordpress, and clean install of latest version of Dynamix. Have it install the required plugins, add a new test page, and add a single image to that test page with visual composer.

    If you try to add an image using single image on visual composer, it will look like it worked and show the thumbnail in the admin, but when you publish the page, the image prints on the page with an empty src, and does not show up. The caption will show up.

    Any help would be appreciated!

    http://greggorrmarine.com/images/ss1.jpg
    http://greggorrmarine.com/images/ss2.jpg
    http://greggorrmarine.com/images/ss3.jpg

    (e.greggorrmarine.com/test-page/ is the url)

    Thank you!


    Joe Regan
    Participant

    Looks like another user has seen this as well.

    http://stackoverflow.com/questions/21525870/empty-images-in-wordpress


    Joe Regan
    Participant

    More information:

    If I turn on lightbox for the single image, and add an alt tag, the image is still missing, but you can click the alt tag and the light box image pops up and works great. That might help with the trouble shooting side..


    Joe Regan
    Participant

    I fixed it! Not sure if this was the best way to fix it or if there is another way, but this is what I changed:

    In image-effects.php change:

    if( of_get_option(‘timthumb_disable’) !=’disable’ )

    to

    if( of_get_option(‘timthumb_disable’) == ‘disable’ )

    That did the trick for me!

    Hope that helps!

    Andy
    Andy
    Keymaster

    Hi Joe,

    There is no need to edit the code – you can switch the image resizer off from Appearance > Theme Options > General > Image Resizer.

    The reason this doesn’t work usually is because of the following reasons:

    1. You’re using your site within a subfolder i.e. mysite.com/wp/
    2. Your hosting doesn’t have GD Library, PHP Image Magick installed or has a permissions issue.

    I’d check with your hosting to see if you have the above enabled and let me know how that goes.


    Joe Regan
    Participant

    Awesome! Thank you for checking into this for me. I never thought about the theme needing those! I turned it off and undid my changes. 🙂

    Thanks!


    Tom ( Support)
    Keymaster

    Thats great, thank you for coming back to us.

    If you are happy with the theme, please take a second to rate the theme 5 stars here.

    Much appreciated 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.