Home / Forums / You Theme Support / Button Email link in footer doesn't work & images not responsive

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • heli
    Participant

    Hi Edcel,

    Hope that you’re well.

    I just had a couple of quick questions re the site I’m currently building using the You Theme (based on the Construction Demo)

    1. The Button Link in the footer is not working – I’ve tried various permutations of the code with no luck. I was wondering if you could point me in the direction of where I’m going wrong please? The code I’m using in the footer widget is as follows;

    Let us help you with your business. [vc_btn title="CONTACT US" style="flat" link= a href="mailto:info@XXXXXXXXX.co.uk"]

    2. Adding a margin of 150px worked great to align the top images properly in a wide screen however I’ve noticed that on smaller screens (especially mobiles) the image moves up so that it overlays the header and only the bottom part of the image can be seen. Do you have a fix for that please? I’ve tried adding other margins but can’t seem to get it to work.

    3. Google Map Link on Contact Page is still giving an error message. For the moment I’ve added the Google Maps link as a straight link to Google Maps (opening in a new tab) but if its possible to have the link open in an iframe that would be great).

    I’ve reinstalled a fresh version of the You Theme as you suggested in an earlier reply but unfortunately it hasn’t done the trick!

    As ever, any help you can give would be very greatly appreciated.

    best wishes

    Heli

    PS, link to test site is below in private post


    heli
    Participant
    This reply has been marked as private.

    Hi Heli,

    1. The correct code should be
    [vc_btn title="CONTACT US" style="flat" link="mailto%3Ainfo%40XXXXXXXXX.co.uk"]

    2. Can you please specify which image you are referring to?.

    3. This has been sorted out from the other ticket you opened.

    Thanks!


    heli
    Participant
    This reply has been marked as private.

    Hi Heli,

    The button should be working now. What I did is create the button on a test page then copied the shortcode to the foote.r

    For the images, the best option would be to add a class name to each of them the add a CSS for the specific to increase the top margin on mobile.

    You can add the class name via Row settings, then the CSS will look like this:

    @media screen and (max-width: 1025px) {
        .classnameyouchose{
            margin-top : 170px;
        }
    }

    Thanks!


    heli
    Participant

    Hi Edcel,

    The footer button now works perfectly – thank you!

    Re the Images on the top row. I gave the CSS you suggested a try (both within the custom CSS settings for each page & also within the main mobile custom css in the theme settings section) but no joy with either I’m afraid. I tried various margins sizes but it’s not made a difference.

    I’ve also noticed that there is the same issue with the other site I’ve built using You Theme, the background images to rows don’t scale with the device size on that site either.

    Any other suggestions you might have would be very greatly appreciated as I’m loth to add the top images using Revolution Slider.

    best wishes

    Heli

    Hi Heli,

    I applied the changes to this page and the heads are now visible on mobile:
    http://clients.wide-eyedesign.com/TS1131216/meet-the-team/

    If you want the image to scale down better to show majority of the image, this will require a lot of custom codes. By default, the image will adjust based on the available row space that is why it scales as it is.

    Thanks!


    heli
    Participant

    Hi Edcel,

    Just wanted to say thank-you for all of your work on the above problems – it was very gratefully received!

    The fix you applied to the Meet the Team page worked, however just for future info I also discovered that the thing throwing off the scale-down was the title/breadcrumbs I’d left enabled so that they overlaid the background image. Once I’d turned them off, the image scaled down without adding the fix (still not completely but at least you don’t just see their torso’s on mobiles & tablets)

    Thank you!

    Heli

    You’re welcome, Heli

    Please don’t hesitate to contact us back if you encounter any issues.

    Regards,

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.