Home / Forums / ePix Support / Compatibility with Visual Composer Extensions

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts

  • Andreas Paehge
    Participant

    Hi Andy,

    I realized that your theme is not compatible with Visual Composer Extensions.
    Media at Slide Set manager is empty then -> no pics available any longer.

    BR
    Andreas


    Andreas Paehge
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi,

    That user doesn’t seem to give me access to any of the admin options. The theme is definitely compatible with add-ons, I even have my own addon for VC too.

    Can you make sure the username has admin access and I’ll take a look at the Slide Set manager.

    PS. Visual Composer does not work with Slide Sets, only Posts and Pages.


    Andreas Paehge
    Participant

    Hi,

    sorry, I forgot to enable role for the user.

    I’m not talking about Visual Composer. I’m talking about Visual Composer Extensions. Please enable the plug in and see the effect in Slide Set Manager, when you open an existing set.
    It’s empty then. Seems to be a side effect.

    Andy
    Andy
    Keymaster

    Hi,

    I thought you meant all extensions, that’s why I said it is compatible as I’ve written my own for VC. 😉

    It’s just the “Composium – Visual Composer Extensions” plugin that has the issue, “Ultimate Addons for Visual Composer” works fine with the theme.

    Unfortunately I can’t diagnose the issue as it causes not errors in the admin. The only thing I can suggest is changing some of the options on the “Composium – Visual Composer Extensions” to see if it changes anything.

    Also, have you tried running just the theme, Visual Composer and the “Composium – Visual Composer Extensions” plugin to see that there isn’t another plugin adding the issue.


    Andreas Paehge
    Participant

    😉

    Many thanks for investigating the issue. First I checked VC + VCE only, but nothing changend. Then I checked VCE switches and found out, that it is related
    to “Manage Custom Post Types”. All three switches (“VC Team” Post Type, “VC Testimonials” Post Type, “VC Skillsets” Post Type) have to be disabled. Why? I don’t know.

    Andy
    Andy
    Keymaster

    That would suggest that their post types are disrupting the Slide Set post type somehow. Unfortunately at this time ( unless you can ask them why that may be ), disabling them would be the only option for both of them to play nicely together. Strange though as the theme works with so many other plugins that use custom Post Types.


    Andreas Paehge
    Participant

    Opened a VCE ticket. Let’s see if they have an idea.


    Andreas Paehge
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi,

    I’m using 1.2.0 too, however that sheds light on why that is happening now. Mine has a slightly modified version of the script ( there was no way around modifying it at the core ).

    Unfortunately there is not a lot that can be done, whilst those options are enabled. I am looking at separating the functions in the future, but I’ve already tried and it’s not a straight forward task.


    Andreas Paehge
    Participant

    Hi Andy,

    that’s not a big problem for me, cause I do not need this additional VCE functions.

    VCE developer wrote me this. May be an option for you too:

    “just so you know, the official v2.0.2 of the same helper class has just been released two days ago, officially introducing v2 of the helper class, which until just then was still in BETA. As it is now officially released, we will switch to that new version as well, rather sooner than later.”

    Andy
    Andy
    Keymaster

    Thanks for the info, I’ll be updating soon too!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.