Home / Forums / DynamiX Support / Contact Form Issue

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts

  • David Schwam
    Participant

    (My apologies if this is a duplicate of my question on Enquiry Forms… I checked the forum but couldn’t find my post anywhere.)

    I developed a website using Dynamix for an organization on my own hosting account. I had the webmaster of the previous site (who was using a different hosting provider) change the A Record of the DNS over to my IP address. Everything works great with the exception of the standard Contact Us form.

    Before the A Record switch, the contact form worked perfectly. Now, it sends the email, but doesn’t clear the form or display the “Thank You” message. Obviously I need to make some sort of change in the code – but am not sure where to make it or what to change. I am a complete novice with .php and Javascript so I don’t want to poke around too much on my own.

    Here is the set up… I am doing this all in a subdirectory of my domain.

    http://www.old-site.org —> A Record points to mysite.com —> I have updated the .htaccess and the .index in my root to point to my subdirectory per the WordPress instructions so it now goes to my subdirectory (e.g. mysite.com/subdirectory)

    When the user goes to http://www.old-site.org my site loads up with the http://www.old-site.org in the URL line of the browser.

    Sorry if this is confusing.

    Andy
    Andy
    Keymaster

    Hi David,

    Definitely is a little confusing, the script uses PHP mail to send the script, if it doesn’t receive the correct response from the server, this is where it will cause issues. Do you have a link to your actual site, I can see what is happening a littler clearer.


    David Schwam
    Participant

    Absolutely. The official URL is http://www.temple-sinai.org

    Behind the scenes the “A” Record for the old hosting provider is pointing to an IP address for http://dialtone-productions.com with the WordPress and Theme installed in a subdirectory (dialtone-productions.com/sinai) which is where I did all my development.

    Thanks for your help!!


    David Schwam
    Participant

    Andy,

    Just wanted to let you know that your test messages from my Contact Us form are coming through loud and clear.

    Andy
    Andy
    Keymaster

    I see what you mean, it’s not throwing any errors either. This maybe something that your hosting will have to resolve. The script is quite simple.

    Try editing DynamiX/lib/inc/contact-send.php and remove the following line for starters( it’s a long shot ):

    if($_POST[$id.'siteURL']) die('email send failed');

    The script appears to die in this file:

    DynamiX/lib/inc/contact-send.php

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.