Home / Forums / ePix Support / Couldn't connect to host & empty media library

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Ian Speight
    Participant

    Hello,
    I’m fairly new to WordPress & PHP/CSS in general. I love the epix theme, but I have a problem, or maybe two:

    • On the Admin console, and on certain plugin display pages (the “Photo Gallery” plugin for example) I am getting “couldn’t connect to host” messages. I have tried to reinstall WordPress, and also the theme, but with no luck. Can someone point me in the right direction?
    • The standard Media Library in thumbnail mode, as well as the “Media File Manager Advanced” plugin cannot load the media files when the theme is loaded.

    Both these problems disappear when the theme is changed to a default one.
    I have tried deactivating all plugins, but as long as the theme is active the problems persist.

    Hours of Googling have not found me any solutions, and I am sure that it is due to some configuration or installation issue, but I have reached a dead-end. Can anyone point me in the right direction?
    For anyone interested to see the “couldn’t connect to host” appearing in the “Photo Gallery” plugin, please look at the “Galleries” link on my blog:
    http://www.sp8photo.com Go right down to one of the images in lightbox mode (I know the thumbnails aren’t working at the moment). The message appears at the top of the lightbox.

    • This topic was modified 2 years, 5 months ago by  Ian Speight.
    • This topic was modified 2 years, 5 months ago by  Ian Speight.
    Andy
    Andy
    Keymaster

    Hi Ian,

    That’s very strange. I can’t see why the theme would interfere with the plugin like that.

    Can you post your WP login details and I’ll take a look into why this maybe happening.


    Ian Speight
    Participant
    This reply has been marked as private.

    Ian Speight
    Participant

    A correction to my original post: since I had problems with the Photo Gallery plugin (nothing to de with these errors) I have removed it, so you can no longer see the “couldn’t connect to host” messages unless you have console access.

    Andy
    Andy
    Keymaster

    Hi Ian,

    Can you check to see that no other plugins are interfering please. Please try disabling all plugins apart from the ones that come with the theme e.g. Visual Composer.


    Ian Speight
    Participant

    I deactivated all except:
    Advanced Excerpt (recommended for your theme)
    Polylang (I dare not deactivate it because of the work of translation)
    WPBakery Visual Composer (as you suggested).

    I now get the following error:

    couldn’t connect to host
    Warning: Invalid argument supplied for foreach() in /srv/disk7/1855646/www/sp8photo.com/wp-content/themes/ePix/lib/adm/inc/theme-updates/class-envato-wordpress-theme-upgrader.php on line 200

    and the media library still does not work.

    I reactivated the Envato WordPress Toolkit hoping to get rid of the second error, but it did not go away. Last week Envato refused to help with this problem.
    Reactivating the other plugins got rid of the Envato ‘invalid argument’ error, but left me the ‘couldn’t connect’ error.

    I am not sure how safe it is to deactivate the Polylang plugin. If you want I can try, but I have spent quite some time setting up the multilingual aspect, so I would not like to jeopardise this.

    Finally: my initial WordPress installation was done using the default installer provided by my hoster. I have used the WordPress ‘reinstall’ functionality several times to try to solve this problem, as well as updating to the latest version when it came out last week. If it could help, I could try to reinstall from scratch, but I will need to find some tutorial to avoid losing my existing content.

    Andy
    Andy
    Keymaster

    Hi,

    I’ve managed to get it working. It appears to be an issue with the theme updates admin page. I’ll look into this and try to resolve for you.

    Strangely, I’ve not had any other reports of this.


    Ian Speight
    Participant

    Hi Andy,

    thanks a lot for your reactivity on this issue. I am looking forward to the update.

    Ian.


    Ian Speight
    Participant

    Thank you very much Andy. It works perfectly now.

    Ian.

    Andy
    Andy
    Keymaster

    You’re welcome Ian, have a nice day!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.