Home / Forums / DynamiX Support / Display issue on Homepage when composing post with Visual Composer

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts

  • Vipin Ramdas
    Participant

    Hi,
    I’m having strange issues when composing a post using Visual COmposer. When I make a post using Visual composer, the excerpt on my home page is not displayed correctly. The 3 dots which are meant to be after the exceprt come before and the text does not wrap around the image. If you see my website http://www.vipinramdas.com, you will notice that the 1st 2 posts have the 3 dots before the excerpt while the others are fine. I tried the same post without visual composer and it ws fixed. This is is why I think it has something to do with the Visual Composer.
    Thanks
    Vipin


    Tom ( Support)
    Keymaster

    Hi Vipin,

    I am not sure exactly why this is happening. Please can I do some digging on your site to find out what the issue is?

    Can you first make sure you are using the latest version of WordPress, DynamiX and Advanced Excerpt to see if that is the issue first.

    Please set your reply to private and provide your URL/login details so I can take a further look for you.

    Kind regards,
    Tom


    Vipin Ramdas
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Vipin,

    I have managed to remove the 3 dots appearing in the strange places. Also, Andy has recently been working on the lay out of this and it will be released in the next version of DynamiX. But if you want to provide your FTP details, he can put this snippet of code into your site so it works correctly.

    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Thanks Tom but weren’t the three dots meant to appear at the end of the excerpt?. Will the Layout fix the issue I see where the excerpt does not start next to the image for these posts? Also when is the next release out?Thanks for your support.


    Tom ( Support)
    Keymaster

    Hi Vipin,

    The dots were appearing in the wrong place as they were getting confused with the Visual Composer content. The new layout should fix this also and we can add them back in.

    The next update will be out soon, I cannot put a data on it but if you require the layout change sooner rather than later then please provide your FTP details and Andy will sort this for you.

    Kind regards,
    Tom


    Bram Kastelijns
    Participant

    Hi Tom,

    I have exactly the same problem and I haven’t seen a new update of your theme since this thread. Could you fix it for me if I provide you my FTP details?

    Kind regards,
    Bram


    Bram Kastelijns
    Participant

    I have already found what the solution is, delete the first vc short code from the blog post. But if you made changes to a post, it will automatically add the code to it, so it is a bit annoying. Hopefully you will take care of it in the next update. But I have add a custom read more in the advanced excerpt settings, how can I remove the ‘Read more’ that is generated by WordPress (or theme).

    Kind regards,

    Bram Kastelijns


    Bram Kastelijns
    Participant

    I found out that I have to delete more vc short codes, otherwise they will be visible in the post, could you please write a snippet or a code for me?

    Bram


    Tom ( Support)
    Keymaster

    Hi Bram,

    Try playing with the settings within Advanced Excerpt to not display shortcodes. This should remove the VC shortcodes from the Excerpt.

    If you want me to remove the read more that is put there by WordPress, please supply me with your blog URL and I will write up some CSS for you.

    Kind regards,
    Tom


    Bram Kastelijns
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Bram,

    I have added the following CSS to Appearance > Theme Options > Customize > Custom CSS to hide the read more.

    p a.read-more {
    display: none !important;
    }
    

    Hope this helps.
    Tom


    Bram Kastelijns
    Participant

    Hi Tom,

    Thanks for your time, the read more is invisible but my custom advanced excerpt (Lees meer) also if I remove the vc short codes from the blog post. You can check it on the homepage http://www.bloggersnetwork.nl and scroll down to recent posts row. On the left you see the posts where I didn’t remove the vc short code, there is the ‘Lees meer’ visible and on the right the posts where I did remove it. Strange things are happening…;)

    Hopefully you can help me out!

    Kind regards,
    Bram


    Tom ( Support)
    Keymaster

    Hi Bram,

    I am not entirely sure what you mean now. I think you have something different to the original post.

    Are you saying that you do not want your custom ‘Lees meer’ to appear? But you want the standard WP one to? Please can you explain this further as I am getting slightly confused now.

    Kind regards,
    Tom


    Bram Kastelijns
    Participant

    Hi Tom,

    What I meant is that I wanted to make the ‘Read more’ (by wordpress) to disappear and only show the ‘lees meer’ (advanced excerpt). After you had put in the code, both of them disappear when I delete the VC short codes from a blog post. But today, both are visible right now again… Strange things are happening…

    Kind regards,

    Bram

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.