Home / Forums / DynamiX Support / Dropdown menu hidden behind embedded video

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts

  • Peter
    Participant

    Hello Andy and all the ships at sea:

    Just moved DynamiX from my test site to the main one, and notice that on pages like this http://bestlifemoments.com/weddings/ the menu for "Montages" appears hidden behind the embedded video. You can see the full length of the menu if you click on a page without a video, like here http://bestlifemoments.com/about/timing/

    Not sure what's up but will certainly appreciate your suggestions. Child theme 1 and DynamiX 2.8.2 are installed.

    Regards,

    Peter

    Andy
    Andy
    Keymaster

    Hi Peter,

    How did you embed the video? 


    Peter
    Participant

    Pasted in HTML code from Animoto. Should I have used shortcode?

    Andy
    Andy
    Keymaster

    Yes probably best to use the Vidoe Shortcode as their code doesn't have the right parameters for handline the z-index issue you're experiencing. 


    Peter
    Participant

    Not working via the shortcode. I used the "flash" type of video in the dropdown and there was nothing on the page. Here' s the code from Animoto in hopes that you'll have a suggestion (ignore "<tag>"):

    <tag>

    <object id="vp1KioV2" width="854" height="474" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000"><param name="movie" value="http://static.animoto.com/swf/w.swf?w=swf/vp1&e=1309890947&f=KioV27TZ0dGGlZbByliZ5g&d=247&m=p&r=360p+480p+720p&volume=100&start_res=720p&i=m&ct=Click%20to%20visit%20us%20on%20the%20Web&cu=http://bestlifemoments.com&options="></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed id="vp1KioV2" src="http://static.animoto.com/swf/w.swf?w=swf/vp1&e=1309890947&f=KioV27TZ0dGGlZbByliZ5g&d=247&m=p&r=360p+480p+720p&volume=100&start_res=720p&i=m&ct=Click%20to%20visit%20us%20on%20the%20Web&cu=http://bestlifemoments.com&options=&quot; type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="854" height="474"></embed></object>

    <tag>

    Thanks, Andy.

    Andy
    Andy
    Keymaster

    add the param name

    <param name="wmode" value="transparent"></param> 

    That should do the job. 


    Peter
    Participant

    Thanks, Andy. Not knowing any better, I added the code you sent to the embed code for the video after the other param values, and it did not make any difference. The dropdown is still not visible on top of the video. Perhaps I inserted the code in the wrong place? Where should it go?

    Andy
    Andy
    Keymaster

     

    This is the code I use for embedding. Copy and paste your movie details into it and try that. This includes IE support aswell. 

     


    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="350" height="140">

    <param name="movie" value="/wp-content/uploads/2011/06/flash.swf">

    <param name="wmode" value="transparent">

    <param name="allowfullscreen" value="true">

    <param name="allowscriptacess" value="always">

    <!--[if !IE]>-->

    <object type="application/x-shockwave-flash" data="/wp-content/uploads/2011/06/flash.swf" width="350" height="140">

    <param name="wmode" value="transparent">

    <param name="allowfullscreen" value="true">

    <param name="allowscriptacess" value="always">

    <!--<![endif]-->

    <div>

    <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player"></a></p>

    </div>

    <!--[if !IE]>-->

    </object>

    <!--<![endif]-->

    </object>

    Peter
    Participant

    Hmmmm. Thanks for the suggestion but I'm a bit stumped by lack of knowledge. You can see the embed code for the animoto video in the thread above. Where exactly in your code would I paste all or parts of that code? Regrets that I know only enough to get myself into trouble 😉

    Andy
    Andy
    Keymaster

    I doesn't allow me to test it for some reason. 

    try this though


    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" height="474" id="vp1KioV2" width="854">

    <param name="movie" value="http://static.animoto.com/swf/w.swf?w=swf/vp1&amp;e=1309890947&amp;f=KioV27TZ0dGGlZbByliZ5g&amp;d=247&amp;m=p&amp;r=360p+480p+720p&amp;volume=100&amp;start_res=720p&amp;i=m&amp;ct=Click%20to%20visit%20us%20on%20the%20Web&amp;cu=http://bestlifemoments.com&amp;options=" />

    <param name="allowFullScreen" value="true" />

    <param name="allowscriptaccess" value="always" />

    <param name="wmode" value="transparent" />

    <embed allowfullscreen="true" wmode="transparent" allowscriptaccess="always" height="474" id="vp1KioV2" src="http://static.animoto.com/swf/w.swf?w=swf/vp1&amp;e=1309890947&amp;f=KioV27TZ0dGGlZbByliZ5g&amp;d=247&amp;m=p&amp;r=360p+480p+720p&amp;volume=100&amp;start_res=720p&amp;i=m&amp;ct=Click%20to%20visit%20us%20on%20the%20Web&amp;cu=http://bestlifemoments.com&amp;options=" type="application/x-shockwave-flash" width="854"></embed>

    </object>

    Peter
    Participant

    Once again, problem solved! Thank you so much for the fix and for the fast response. I have a couple other pages where the same condition exists, so I'll try and replace the specifics for the other videos from what you sent.

    Thanks again, Andy.


    Peter
    Participant

    Hey Andy:

    What's the possibility of you adding an Animoto embed choice for your galleries and shortcode in future revs? I'm using the fix you gave me the other day (using your embed code) but it would sure be nice if I didn't have to do so much copying and pasting. I have many Animotos on my site and update them frequently which of course requires new embeds. I'm sure you have bigger fish to fry, but it sure would be slick.

    Thanks!

    Andy
    Andy
    Keymaster

    Peter
    Participant

    Indeed, in reality it does. No dropdowns hiding behind the vid, either! Thanks so much, Andy.


    Peter
    Participant

    Slight revision to my previous post. The only thing that the shortcode does not provide for — or I am not doing it correctly — is for the video to be full-screen using these bits: ></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always". When I used your previous bit of code (above) that allowed for the full-screen view, all was good. But viewing full-screen is an important aspect, and I tried pasting that part of the code into the URL path and it did not work.

    Thoughts? Otherwise, I can just continue to use your embed code. Maybe adding full-screen view to your shortcode is something for a future rev.

Viewing 15 posts - 1 through 15 (of 24 total)

You must be logged in to reply to this topic.