Home / Forums / ePix Support / Embeding Facebook video in a gallery?

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Jeff Ross
    Participant

    Is it possible to embed a facebook video into a grid gallery with a still image as a thumbnail? The only link I can find to this video is on Facebook:
    <div id=”fb-root”></div> <script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = “//connect.facebook.net/en_US/all.js#xfbml=1″; fjs.parentNode.insertBefore(js, fjs); }(document, ‘script’, ‘facebook-jssdk’));</script>
    <div class=”fb-post” data-href=”https://www.facebook.com/photo.php?v=157916684300272″ data-width=”466″><div class=”fb-xfbml-parse-ignore”>Post by J.Jill.</div></div>

    But, it is meant to be embeded directly. When I do the normal method and use this as the media link, I get that code under the still image thumbnail. Is there a way I can use this video? Thanks

    Jeff Ross
    http://anneross.com/?page_id=22


    Tom ( Support)
    Keymaster

    Hi Jeff,

    Unfortunately this is not possible to do as Facebook use a script that the theme/WordPress cannot put into galleries. You will need to download the video and upload it to your site then use JW Player to embed this.

    Hope this helps.
    Tom


    Jeff Ross
    Participant

    Thanks for the quick response. I thought that might be the case, so I just added the facebook video’s embed code under my grid gallery using the raw .html element and it works/plays fine, just not as a part of the grid gallery above it. The result can be found here: http://anneross.com/?page_id=22 And I just launched the site this morning! Thanks for the theme and the quick responses in the forum- a big help!


    Tom ( Support)
    Keymaster

    Hi Jeff,

    Sites looking great! One thing I would suggest, for SEO and better userbility. You can change the parmalinks to be the post name instead of /id=3 for example. It will change to mysite.com/about_me for example.

    To do this, go to Settings > Permalinks > Post Name. This is much better for SEO too as Google can actually pick up on exactly what the page is about more so than an ID.

    If you are happy with the theme, please take a second to rate the theme 5 stars here.

    Much appreciated 🙂

    Hope this helps.
    Tom


    Jeff Ross
    Participant

    Thank you for the tip, but I do have a question about changing the permalinks. I did what you describe above (simple) but then none of my liks on the menu work. I switched it back to the default permalinks setting and it all works again. Do I need to refresh something to update all the links? Sorry- probably a newbie question. Thanks!


    Tom ( Support)
    Keymaster

    Hi Jeff,

    If you have added your navigation links through the Appearance > Menus option correctly, the links should change when changing the permalinks.

    When in the Menus panel, select your pages from the left hand column and click Add To Menu. This will add the pages to the menu in the correct way.

    If you are still having issues, please set your reply to private and provide your URL/login details so I can take a further look for you.

    Kind regards,
    Tom


    Jeff Ross
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Jeff,

    I have researched this a bit as I have not heard of this happening before and found people on the WordPress forums saying, This is definitely a server issue – not a WordPress one. Check with your hosts that mod_rewrite is running on your server.

    This seems to be a problem with Jetpack as we have had another user say the same thing. We found out that Visual Composer and Jetpack sharing are not quite compatible yet. Incase they have recently fixed it, have you got the sharing part of JetPack installed? The post also needs to be published for it to be shared.

    I have suggested the following in the past to people having issues with Facebook sharing. Might help you out.
    Try the following plugin to see if this helps you out. Plugin download page here. You can then test your URL by going here.

    Kind regards,
    Tom

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.