Home / Forums / ePix Support / ePix Child Theme – No index.php

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts

  • Masha
    Participant

    Hello,

    I just purchased epix. I´ve uploaded ePix theme, but when I try to upload the child folder throug wp it says that index.php is missing and it can´t install it (it is not within the folder). Uploaded the folder through ftp and the the child theme is not available for activating. Then, I´d created a blank index.php file and I could managed to activate the child theme, but the website throws this:
    {\rtf1\ansi\ansicpg1252\cocoartf1265 {\fonttbl} {\colortbl;\red255\green255\blue255;} \paperw11900\paperh16840\margl1440\margr1440\vieww10800\viewh8400\viewkind0 }

    Then, I copied the index.php file from ePix folder and at least I can see the title and description of the site, but nothing else. In fact, I´ve imported demo data, but nothing else…

    What I´m missing?
    Regards

    Andy
    Andy
    Keymaster

    Hi Masha,

    Are you uploading both the epix and epix-child folder to the /wp-content/themes/ directory ?

    It doesn’t require an index.php file, I’m unsure why you’re receiving that message.


    Masha
    Participant

    Hi Andy,

    Yes, both folders are inside themes directory. Should the child theme directory have an index.php file inside? There was none…

    Regards


    Masha
    Participant

    Deleted index.php and web is blank. I guess… which php version requires?

    Andy
    Andy
    Keymaster

    There shouldn’t be an index.php file, I’m unsure why that message is appearing. What happens when you activate the core theme ( epix ).


    Masha
    Participant

    Hi Andy,

    If setted as homepage my latest posts appears fine. But in appearance-themes, the child appears like this after deleting index.php file:

    Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    ePix Child Theme Template is missing.

    Andy
    Andy
    Keymaster

    Hi Masha,

    My apologies, I’ve created a new version of the ePix-Child theme for you.

    Please download it from http://help.themeva.com/tmp/epix/ePix-Child.zip ( unzip and upload ).


    Masha
    Participant

    It works!

    Thank you very much for your quick assistance.

    Best regards


    Masha
    Participant

    Hello,

    I thought it was working, and inf fact it does, except the Home page. No matter what I do, it always displays empty… Any suggestion?

    Regards


    Tom ( Support)
    Keymaster

    Hi,

    Do you have a link to your site so I can take a further look? You might not have selected the data source for the gallery on your home page, that is one thing to check.

    Kind regards,
    Tom


    Masha
    Participant

    Hi Tom,

    Yes, it´s Vividmediaholding.com. If you visit /contacts you can see it´s working, but not the homepage.

    Thank you


    Masha
    Participant

    Solved! As you said, it was only the data source.

    Thank you very much for your support.

    Regards

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.