Home / Forums / DynamiX Support / Error after upgrading to PHP 7.1

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Natalie
    Participant

    My host just upgraded to PHP 7.1 and now I see an error on the blog listing page:

    Warning: Illegal string offset 'width' in /home1/goldenga/public_html/wp-content/themes/DynamiX/lib/inc/classes/blog-class.php on line 231
    
    Warning: Illegal string offset 'crop' in /home1/goldenga/public_html/wp-content/themes/DynamiX/lib/inc/classes/blog-class.php on line 241

    How would I fix this? Here is the url: http://goldengatebpo.com/category/press-releases/

    Hi @gediweb

    What version of Dynamix are you using? If it’s the latest version, there are 2 options you can consider:

    1. Turn off WP_DEBUG on wp-config.php. This will hide these warnings since they do not have much impact on the site yet since they are just warnings and not fatal errors

    2. Downgrade PHP version.

    A newer version of the theme will be released soon and it should behave better on PHP7 compared to the current version.

    Regards,


    Natalie
    Participant

    I’m using the latest.

    1. My WP_DEBUG in wp-config.php was already off, so it must have been controlled by something else.
    2. I was able to downgrade from PHP 7.1 to PHP 7.0 and that solved the problem

    Thanks!

    Just to confirm, has this issue already been resolved, @gediweb?

    Regards,


    Natalie
    Participant

    yes. Downgrading to 7.0 solved the issue. Thank you!

    You’re welcome, @gediweb

    If you like the theme, please don’t forget to rate it at https://themeforest.net/item/dynamix-business-corporate-wordpress-theme/113901?s_rank=1

    Regards,

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.