Home / Forums / ePix Support / Extended Latin character sets

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • kacor
    Participant

    How and what do I need to change for showing Extended Latin character sets? Some characters the browser doesn’t show correctly. I am using Oswald font.


    Tom ( Support)
    Keymaster

    Hi,

    I did a bit of searching and found the following information.

    There is however a fantastic plugin named Convert WP Database to UTF-8. This plugin adds a sub-menu page named “UTF-8 DB Converter” to the Plugins Menu. Simple click on “Start converting” and the plugin will automatically execute the required SQL queries to alter the character set and collation of all your existing WordPress tables.

    You only need to do it once per website, and the problem is fixed for good. You can then uninstall the plugin.

    It does show it is an old plugin but people have used it recently and reported it does still work. If you don’t want to do it this way, you would need to edit the MySQL database directly.

    Please be sure to back up your database prior to completing this.

    Original post, here.

    Kind regards,
    Tom


    kacor
    Participant

    The plugin didn’t help me..The problem still persists and some characters, like ?,?,?,? are showed as bold in mz text. Where is the database located? What i need to edit there?


    Tom ( Support)
    Keymaster

    Hi,

    I recommend following the link provided but if you are not familiar with MySQL I wouldn’t start editing things. Maybe ask your hosting company.

    What might be the case is that the font you have chosen does not support different character sets. If you use the standard font, does the text appear correctly?

    Kind regards,
    Tom


    kacor
    Participant

    Last time I used similar WP theme.I simply added: &subset=latin,latin-ext in header.php and it works well.. The whole string looks like this:
    <!– Fonts –>
        <link href=’http://fonts.googleapis.com/css?family=<?php echo get_theme_option(“additional_font”); ?>:400,300,700&subset=latin,latin-ext’ rel=’stylesheet’ type=’text/css’>

    Which file include something like this?I will try to change it.
    Thanks


    Tom ( Support)
    Keymaster

    Hi,

    Ah I see what you mean. You can add the following to make this work. Go to Appearance > Theme Options > General > Google Fonts.

    Font URL: Oswald&subset=latin,latin-ext
    Font Name: Oswald

    Then go to the live skin customizer and choose the Oswald on your headings.

    Kind regards,
    Tom


    kacor
    Participant

    do you mean Typography? I see just Custom Google Font One and then URL Name and CSS Name…I filled just URL Name and problem still persist….


    kacor
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    Please try this alternative method. Download the code here and paste it into Appearance > Theme Options > Customize > Javascript.

    Paste the following code into Appearance > Theme Options > Customize > Custom CSS.

    h1,h2,h3 {font-family:Oswald;}
    

    Go into Appearance > Customize and set your fonts to Oswald again.

    Please let me know how you get on.

    Kind regards,
    Tom


    kacor
    Participant

    Still the same…
    Font URL: Oswald&subset=latin,latin-ext
    Font Name: Oswald
    added in Appearance > Theme Options > General > Google Fonts, changed all characters to bold..i don’t like it..sorry

    Andy
    Andy
    Keymaster

    Hi,

    It was because you had Oswald set in the Customizer – I’ve now set the Font Family for the general font to the default.


    kacor
    Participant

    Thanx, now it looks perfect.


    kacor
    Participant

    something goes wrong, sorry. first time, when I load the page, menu font looks good. If I make click on menu, the menu font will change to bold…


    Tom ( Support)
    Keymaster

    Hi,

    When you first enter the page the font has to load up, it will momentarily change from the standard font to the custom Google font. This is just the way Google fonts load, unfortunately there is nothing we can do about it, it would be the same for any theme/website.

    Kind regards,
    Tom

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.