Home / Forums / DynamiX Support / Extra code automatically generated

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Paul Kunkel
    Participant

    Hi Andy:

    If you look in the classic text mode of my site (any page eg http://wangjingwei.org/wang-jingwei-life-en/remembering-wang-jingwei/), you will see multiple tags like <span style=”font-weight: 400;”> all over. This is generated automatically but seemingly randomly. Now my site is loading very slowly, I am wondering if this has something to do with it. When I removed some, it seems to have no effect on the front-end. Is all this necessary? If not, can I get rid of it and undo whatever it is that generates these tags?

    Thank you.

    • This topic was modified 11 months, 3 weeks ago by  Paul Kunkel.

    Paul Kunkel
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Paul,

    I’ve had a look through a few of the pages and I do not see what you’re describing – have you resolve the matter?

    Here’s what I see:


    Paul Kunkel
    Participant

    Andy, please log in and view it on the back-end editor, in the class text mode.

    Andy
    Andy
    Keymaster

    Hi Paul,

    My apologies, I misread your post.

    It looks like the span tags were copied in from somewhere – they won’t have an affect on the speed as they’re just changing the font weight ( which is the same font weight used by default anyway ).

    I do not recommend the caching plugin you’re using – it seems overly complicated and I’ve never had good results with it. I personally would clear the cache, remove that plugin and use either WP Fastest Cache ( quickest and simplest to use ) or WP Super Cache and Autoptimize combined that has more control.

    See if that has any affect on the load speed.


    Paul Kunkel
    Participant

    Thank you, Andy. I most certainly don’t copy the span tags in, it is strange that they are automatically generated. Is there a way to stop this? If nothing else, it makes back-end editing very difficult. They are there on many pages, like http://wangjingwei.org/wang-jingwei-life-en/bio/, http://wangjingwei.org/chen-bijun-en/ http://wangjingwei.org/wang-jingwei-life-en/associations/ . Do you recommend getting rid of them? Is there a way to get rid of these tags already on the pages except manually? I have been building this site for a couple of years, seems to start happening within the last year. Could you please check to see if this has anything to do with this http://acoda.com/forums/topic/page-title-font-artificially-bolded/?

    I got rid of the caching plugin.

    I have another question: I added a 512×512 site icon, but it is not getting picked up when I tried to save the site on my ipad.. That is what the site icon is for, isn’t it? Can you advise why this is so?

    Thank you for your help.

    Andy
    Andy
    Keymaster

    Hi Paul,

    You won’t see the span tags from where you’re copying them from. I.e. earlier I copied some text from a PDF and it carried span tags that adjusted the line-height etc. The only way around this is to enable the “Paste as text” option within the WordPress editor ( within the kitchen sink ).

    You could then copy the text from the front end of the site and then re-paste it in with the above option enabled.

    Where have you set the site icon, do you mean the Favicon under Appearance > Theme Options > Header? Have you set it a png format?


    Paul Kunkel
    Participant

    Ok, this makes sense. I was copying from Google docs, this might have been the problem. So I would have to manually get rid of the span tags already there, right?

    I set the site icon (png file) in Customizer Site Identity. I have favicon set which works fine. Please see https://www.dropbox.com/s/b3fn0kzdie6au0m/Screen%20Shot%202016-02-04%20at%2010.30.38%20AM.png?dl=0

    Andy
    Andy
    Keymaster

    No, if you enable the “Paste as Text” button within the WordPress text editor, it will strip all span tags 🙂

    I’ll look into this, it looks like WordPress have added a favicon of their own now. For now, you can use the Appearance > Theme Options > Header > Favicon option instead.


    Paul Kunkel
    Participant

    Yes, the favicon option does work.

    Thanks.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.