Home / Forums / ePix Support / Gallery Images displaying description instead of title

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • Hanbe
    Participant

    Hi Andy,

    I updated to the latest version of epix a few days ago and have since noticed that the gallery light box images are displaying the image description instead of the title. Is there a way to fix this? I use the description to add my keywords and would prefer this isn’t displayed. Heres a example page

    http://hannahcaldwellphotography.com/food-photographer-melbourne

    Thanks,

    Hannah

    Hi Hannah,

    I do not see any description on the page you specified. Can you please elaborate and send us your login credentials?

    Thanks!


    Hanbe
    Participant
    This reply has been marked as private.

    Hi @hanbe,

    Thank you for elaborating.

    I do see that issue that you described now. I have coordinated this with the developer and we will get back to you once we have figured this out.

    Regards,


    Hanbe
    Participant

    Hi Edcel,

    just following up to see if you have a solution to the issue above?

    Thanks

    Hi Hanbe,

    I will make a follow-up with the developer and get back to you on this.

    Our apologies for the delayed resolution.

    Regards,

    Andy
    Andy
    Keymaster

    Hi,

    Sorry for the delay on this. It’s due to you having an ALT value in the Media Library. It checks to see if there is a ALT tag, if there is, it will use it, if not, it will use the Title. This was implemented because most users wanted to display ALT tags, instead of the image title.

    You can override this by one of two ways.

    1. Remove the ALT tag from each image ( time consuming I know ).
    2. Edit the following file to enable just the title to show. The file you need to edit is ePix/lib/inc/grid-gallery-frame.php

    And locate the following lines ( there are two you need to change )

    ( !empty( $NV_alt ) ? $NV_alt : $NV_posttitle )

    change to just:

    $NV_posttitle

    I hope that helps?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.