Home / Forums / DynamiX Support / Gallery Slide Set – missing an overlay setting

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Peter
    Participant

    Hi Andy:

     

    In DynamiX 2.9, in the Gallery Slide Sets “Title Overlay” drop-down, there is no setting for “Center Right Light,” although there are no less than three entries for “Center Left Light.” This is the first time I’ve used the overlays, so I can’t say if it existed in previous versions.

     

    Is there a way I can fix it in CSS or is this a bug fix for future revs?

     

    As always, thanks for the great support.

     

    Regards,

    Peter


    Peter
    Participant

    Bump

    Andy
    Andy
    Keymaster

    Hi Peter,

     

    Sorry I must have missed this – that’s interesting, I’m not sure how long it’s been like that for. You can edit DynamiX/lib/adm/inc/gallery-creator.php and search for the following segment of code.

     

    $overlay = array(“Disabled”,”Center Left Light”,”Center Left Light”,”Center Middle Light”,”Center Left Dark”,”Center Right Dark”,”Center Middle Dark”,”Center Left Light”,”Top Left Light”,”Top Right Light”,”Top Middle Light”,”Top Left Dark”,”Top Right Dark”,”Top Middle Dark Text”,”Bottom Left Light”,”Bottom Right Light”,”Bottom Middle Light”,”Bottom Left Dark”,”Bottom Right Dark”,”Bottom Middle Dark”);

     

    change to

     

    $overlay = array(“Disabled”,”Center Left Light”,”Center Right Light”,”Center Middle Light”,”Center Left Dark”,”Center Right Dark”,”Center Middle Dark”,”Top Left Light”,”Top Right Light”,”Top Middle Light”,”Top Left Dark”,”Top Right Dark”,”Top Middle Dark Text”,”Bottom Left Light”,”Bottom Right Light”,”Bottom Middle Light”,”Bottom Left Dark”,”Bottom Right Dark”,”Bottom Middle Dark”);


    Peter
    Participant

    Did that, got this:

    Parse error: syntax error, unexpected T_STRING, expecting ‘)’ in /home/peter6/public_html/wp-content/themes/DynamiX/lib/adm/inc/gallery-creator.php on line 244

    Thoughts?

    Andy
    Andy
    Keymaster

    Hi Peter,

     

    It’s because of this forum formatting the characters. Try copying the following

     

    $overlay = array("Disabled","Center Left Light","Center Right Light","Center Middle Light","Center Left Dark","Center Right Dark","Center Middle Dark","Top Left Light","Top Right Light","Top Middle Light","Top Left Dark","Top Right Dark","Top Middle Dark Text","Bottom Left Light","Bottom Right Light","Bottom Middle Light","Bottom Left Dark","Bottom Right Dark","Bottom Middle Dark");


    Peter
    Participant

    Perfect. Thanks!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.