Home / Forums / DynamiX Support / Gallery Slide shows wrong/duplicate posts

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts

  • Chris Alford
    Participant

    Hi everyone,

    Hope someone can help because I am going mad! 🙂

    I am trying to fix a Gallery Slider that shows our last 6 posts. It shows posts, in 2 lots of 3, but when the most recent post is always missing and the oldest post of the 6 is duplicated, so it shows up as both the oldest AND the latest.

    I have tried both the shortcode generator and the full Add Post / Slide Set Gallery options but both act the same way. When I was testing I changed the limit on posts so it would just return 1 post, the latest and then it DID return the most recent post. But as soon as I changed the limit to 2 I got the second most recent post (i.e. the oldest of the 2 posts) twice.

    Hope that makes sense and someone can help, I can send a URL if you think it would help.

    Cheers.

    Andy
    Andy
    Keymaster

    Hi Chris,

    I'm not sure I follow – I've seen this sort of thing happen with the grid gallery and that was a plugin causing the conflict. Try disabling all plugins to see if the issue is resolved and then re-introduce one by one. 


    Chris Alford
    Participant

    Hi Andy,

    Thanks for replying to this, your suggestion was helpful (although I've only recently got around to trying out your solution).

    I disabled the plug-ins one at a time and eventually found that the plug-in connected to the problem is called Wishlist Member. Unfortunately it's a key plugin for my site so I can't just get rid of it. I currenty still have the plugin enabled, which means the problem with the Gallery slider is visible on my site. I wondered if you would be able to take a quick look and see if you can see any obvious problem with it?

    The grid view displays correctly. If you see this page the top 3 images are the images that I want to show up on the home page Gallery slider. http://www.loveplaywork.com/category/blog/

    However, on the homepage (http://www.loveplaywork.com/) if you scroll down to Recent Posts you will see that the first image is different, it is in fact the oldest post of the 9 posts selected.

    I have tried upgrading the theme to 2.8.8 but that did not help, I have reverted back to 2.8.7 for now as I had made a couple of style customisations.

    I compared the page source on the homepage with the plugin enabled and disabled and the only difference I could spot was that when the Wishlist plugin is enabled there are a couple of (blank) CSS styles added to the header.

    Hope you can help, or suggest what I can try next, I don't have a lot of experience with this sort of thing,

    Chris

    Andy
    Andy
    Keymaster

    Hi Chris,

    What page is the group slider on? I'll try to see what errors are caused and go from there. 


    Chris Alford
    Participant

    Thanks Andy, much appreciated.

    The slider is on the homepage (http://www.loveplaywork.com/) at the bottom of the screen under Latest Blog Posts (apologies if I've been calling it a slider and it's actually something else). If you look at the first image you see ("Do you need to stop apologising…") and then use the arrow to scroll left, then the image on the right is the same ("Do you need to stop apologising"). This is because that image/post is currently showing up as both blog post 1 and 9 (the limit is set at 9).

    See the grid view on the blog page () that displays the same posts but correctly has the latest blog post as the first image ("The results are in…")

    Thanks, hope you can help, thanks for trying,

    Chris


    Chris Alford
    Participant

    Sorry, grid view is http://www.loveplaywork.com/category/blog/

    Andy
    Andy
    Keymaster

    That's bizarre – I'll have to setup some tests on my server to see if I can reproduce. Does it do it with any other gallery?


    Chris Alford
    Participant

    Hi Andy,

    I've not seen it on any of the others, but I haven't checked them all. I will try a few more on a test page and let you know if I find more examples.

    Cheers.


    Chris Alford
    Participant

    Hi Andy,

     

    I have noticed that using the recent posts short code it not only doesnt show the latest post but repeats some of them too. Did you manage to find recreate the problem on your server?

    Cheers

    Andy
    Andy
    Keymaster

    Hi Chris,

    Again I haven't had any reports of this and from what I've tested I've not seen any issues. I must set some time aside to thoroughly test it. I've bookmarked this and will test again over the next couple of days.

    If you could test in the other galleries that would be great. Thanks!


    Chris Alford
    Participant

    Hi Andy,

    Thanks for getting back to me, I have done some testing and all post/ picture galleries (stage, group slider, grid gallery, accordian gallery on shortcode and slide set gallery) are affected. Basically the latest post is missing, while the oldest post is shown as the newest as well as the oldest. The same thing happens when using the recent posts short code.

    You can see the full list of posts here http://www.loveplaywork.com/category/blog/ (in date order) while at the bottom of this page http://www.loveplaywork.com/ you can see the oldest blog (of the 9 shown) is shown as the first and last post.

    let me know if you need any further information,

    Cheers

     

    Andy
    Andy
    Keymaster

    Hi Chris,

    They are all ordered by date (within additional settings), is that correct? My server doesn't appear to be doing this. I'll setup some more tests and see what happens, I may need to login to your site to see what is happening. 


    Chris Alford
    Participant

    Hi Andy

    Thanks right they are all in date order, newest first. Happy to give you the login to my site if it would help you.

    Thanks for trying to fix this, I owe you a beer!!

    Andy
    Andy
    Keymaster

    Hi Chris,

    Yes send me over your login details via private message and I'll take another look to see what is going on. 


    Chris Alford
    Participant

    Hi Andy, I have sent you the login details of the site. Let me know if you need anything else.

    Cheers

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.