Home / Forums / DynamiX Support / Google Web Fonts not loaded on frontend

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts

  • Luisa Marra
    Participant

    Hi guys,
    I’m having some issues with Google Fonts. I will explain you exactly what I’m doing but I’m not haivng the expected results.

    Under Theme Options > General > Typography
    I have set the following values:

    1. Font Type: Google
    2. Custom Google Font One: (field one) Cookie
    3. Custom Google Font One: (field two) Cookie
    4. Custom Google Font Two: (field one) Noto+Sans
    5. Custom Google Font Two: (field two) Noto Sans

    However in frontend I’m not able to use the web fonts.
    Inspecting the browser requests, the only two requests sent to fonts.googleapis.com is for Open+Sans:400,300 and the second for Open+Sans:400,800,300,700.
    Am I doing something wrong?

    Thanks!


    Ondrej Hrciak
    Participant

    Hello. And I have a problem with the font. I’m trying to use the “Open Sans”, namely subset latin-ext: (http://fonts.googleapis.com/css?family=Open+Sans&subset=latin, latin-ext ‘rel =’ stylesheet ‘type =’ text / css ). In the “Custom Google Font One” I put this link, but no change.


    Luisa Marra
    Participant

    As I intended the documentation you cannot specify the full URL, so you should write just Open+Sans. It would be great if the theme would detect if the specified resource is an URI or just the name of the font.

    However the theme feature I’ve described seems to be broken… or the documentation is incomplete.


    Tom ( Support)
    Keymaster

    Hi,

    I have just tested this again and it is working perfectly for me. Are you on the latest versions of DynamiX and WordPress? Are you selecting the fonts from the font settings within the Live Skin Editor?

    Kind regards,
    Tom


    Luisa Marra
    Participant

    Hi Tom,
    thanks for the reply.
    My wordpress is at version 3.6 and Dynamix has been downloaded the latest week when it was released tha latest release so, i thought all them are at the latest version.

    I’m selecting the fonts from the WordPress menu Apearance > Theme options and then on General tab I’m setting the fonts as described in the documentation page


    Luisa Marra
    Participant

    If i do it from the live skin editor it works correctly but I cannot apply fonts to a specific page content (eg. identified by an ID)


    Tom ( Support)
    Keymaster

    Hi Lusia,

    The fonts are working in the correct way, using the standard theme options there isn’t a way of setting a font to a specific page. This would be a customization. You can request a customization at the Premium Forum here if you need us to complete this for you.

    Kind regards,
    Tom


    Luisa Marra
    Participant

    Hi Tom,

    I think that I was reading bad the documentation… Indeed I left the first part of Google Fonts paragraph:

    Custom Google Fonts

    Add upto two custom Google Fonts. Once the fields have been completed the new fonts will appear within the Appearance ? Themes ? Customize ? Font Settings ? Headings Font Family. See the steps below for how to add extra fonts.

    I don’t need a customization but just I (wrongly) thought that adding the above font names they would be added as custom fonts to each page.

    Sorry again for the wasting of time and I would reconfirm my apreciation for the theme.

    Great work and great documentaion! 🙂


    Tom ( Support)
    Keymaster

    Hi Luisa,

    No worries at all. Glad you got things sorted 🙂

    Kind regards,
    Tom

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.