Home / Forums / ePix Support / Grid Display and Blog Rendering Issue

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts

  • zistudios
    Participant

    Hi, for the first time I’ve added a gallery to a blog page and I’m having the following problems:
    1) When clicking the post link, sometimes only the first three images load and the navigation to the previous post overlaps on the images. If I refresh, sometimes the full gallery will load.
    2) On the Blog list page, I don’t see a way to stop the image grid from also displaying. I would only expect the feature image and the initial text to display
    3) In IE 11, the blog post list page shows the first three images of my grid in the Rockstar Tanya post, but then the text overlays the grid images. This is consistent

    Link to Blog List:http://www.delaunfuller.com/category/blogging/
    Link to Blog Post: http://www.delaunfuller.com/2015/06/12/rockstar-fashionista-tanya/


    zistudios
    Participant

    4) Also, all images from my blog post are displaying on the blog list page. I’m not sure what I’m doing incorrectly. I’ve been using the theme for some time.


    zistudios
    Participant

    UPDATE: Using Advanced Excerpt, I was able to stop the grid of images from appearing on the Category/blog list page. However, issues 1 and 3 are still happening. now it happens in both IE and Chrome. On the single post page the entire comment form overlays with the grid and the grid overlays within itself. When it first loads you can quickly see the images loading up on top of themselves.
    Link to Blog Post: http://www.delaunfuller.com/2015/06/12/rockstar-fashionista-tanya/

    Andy
    Andy
    Keymaster

    Hi,

    I’ve been using browser stack to test this but I can’t replicate it. Do you have a screenshot of what is happening?


    zistudios
    Participant

    Here is a link Roma screenshot. This is from my iPad in chrome. The desktop behaves the same way.
    http://www.delaunfuller.com/troubleshooting/?preview=true&preview_id=3781&preview_nonce=d6b957dfec

    Andy
    Andy
    Keymaster

    I unfortunately can’t see preview pages. Can you post another screenshot please.


    zistudios
    Participant

    Sorry, I forgot to strip the draft parameters. http://www.delaunfuller.com/troubleshooting/

    Andy
    Andy
    Keymaster

    It’s 100% not doing that on any machine I’m using. I tested in Browserstack and it displays normally. Is there any caching plugins being used and have you cleared your browser cache too?


    zistudios
    Participant

    WP Super Cache is installed but the plugin is in Non Active state. I don’t just have caching turned off, but I totally deactivated the plugin after clicking the option to clear all cache files. I’ve cleared my browser cache on all devices. I’m seeing the same thing on four devices in 3 different browsers. I’m even seeing it in browsers I have never loaded the page into. The result is identical on ALL devices and in all browsers. The devices and browsers are:
    – 2 laptops (one windows 7 and one windows 8, google chrome and IE)
    – iPad 3 (google chrome and safari)
    – iPhone (google chrome and safari)

    I’m not certain what else to try. When you load it on your browser, how many images load in the masonry grid?


    zistudios
    Participant

    UPDATE: I just had another person who has never been to my website check, and their computer is doing the exact same thing. Because I don’t want the clients seeing this issue, I’ve updated the link to: http://www.delaunfuller.com/2015/06/12/rockstar-fashionista-tanya-issue/ since I already published the old link to facebook.


    zistudios
    Participant

    OK, unfortunately because of the way my publish plugin works, even when I change the URL, the social published links also “update” effectively. So, hopefully we can figure out a solution to this. because several others are seeing the same issue, I don’t know why you aren’t seeing it in Browserstack. If you try in a standard browser from your machine, what do you see? Also, are what browsers are you checking from your machine directly VS Browserstack?

    Andy
    Andy
    Keymaster

    Hi,

    I’ve managed to replicate it now. It’s to do with the load sequence, the script for the isotope thinks the Grid Gallery is only 80px in height.

    Can you post your FTP details and I’ll do some tests to see what I can do to change this. I’ve never come across it before. One possible explanation is the images, how big are they in their natural format? If they’re very big, the server will take time to resize and that’s possibly why the isotope script thinks the Grid Gallery is only 80px high ( the images haven’t yet loaded ).


    zistudios
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi,

    It looks like I’ve resolved this now. Please clear you browser cache and try loading the page. I’ve added an extra function that checks to see if each image has loaded before applying the “Masonry” effect.


    zistudios
    Participant

    Thanks Andy. In the browsers on my PCs the posts look great; however, on mobile devices (both ipad and iphone) you have to rotate the device, forcing the page to re-render, in order for the images to “uncollapse”. Then once you rotate back, everthing looks good. 1) Can something be done for this? 2) What file(s) did you update so that I can understand how you made this change should I see a similar issue in the future?

    Thanks!

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.