Home / Forums / DynamiX Support / Grid Gallery Alignment

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts

  • MediaLoaf
    Participant

    After the update, our grid galleries seem to be causing alignment issues? Trying to fix this without adding css that will mess with future theme updates. Thanks.

    3rd Column

    Andy
    Andy
    Keymaster

    Hi,

    Can you provide a link to the page please. It looks like a two column, if that’s the case, please try adding this to Appearance > Theme Options > Customize > Custom CSS:

    .gallery-wrap .three_column.columns:nth-child(2n+1) {  
     clear:left;
    }

    MediaLoaf
    Participant

    We are currently working on an internal server so I can’t send a direct link at this time. I’ll see what I can do. The fix you provided did not work and I do know that this problem began after the latest update. All spacing seems to be correct and there is enough room for all three columns, but adding a grid gallery to the third column forces the drop. I’ll post if I can get this somewhere viewable, but if you have any other suggestions in the meantime, I’m all ears. Thank you.

    Andy
    Andy
    Keymaster

    Once it’s live, I can provide you with the fix. However, if you’re using 3 columns – you can try this instead

    .gallery-wrap .three_column.columns:nth-child(3n+1) {
     clear:left;
    }

    MediaLoaf
    Participant

    No luck with that either. I’ll work on getting this live. Thanks for your time.

    One thing I did notice is that between column 2 and 3 there seems to be a random

    <div class=”clear”></div>

    If I remove that it fixes the problem, but can’t seem to find what is causing that code.

    Andy
    Andy
    Keymaster

    I’d really have to see the page to see what is causing it. As soon as you have it on a live server, please post your WP login details and I’ll resolve it for you straight away.


    MediaLoaf
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Josh,

    I’ve added a bit of CSS in for you. It appears to be working fine now.


    MediaLoaf
    Participant
    This reply has been marked as private.

    MediaLoaf
    Participant

    I hate to be a thorn in your side, but it’s something with the extra div that seems to be breaking this. I can remove <div class=”clear”></div> in inspector and the page completely fixes the layout. The extra css doesn’t seem to be fixing the issue. I’ll keep trying to resolve the problem for now. As always, thanks for your help.


    MediaLoaf
    Participant

    If anyone else experiences this:

    I went to each page that had the problem. Opened the page specific CSS and added:

    .clear {
    display:none;
    }

    Probably not the best fix, but it works for now.

    Andy
    Andy
    Keymaster

    Hi,

    For some reason the fix I had created was removed.

    I’ve added this in now:

    .gallery-wrap .two_column.columns:nth-child(2n+1),
    .gallery-wrap .three_column.columns:nth-child(3n+1) {
     clear:left;
    }

    Now all the columns align correctly.


    MediaLoaf
    Participant

    Awesome. Looks great. Thanks again for all your help. Your tech support here has always been top notch.

    Andy
    Andy
    Keymaster

    You’re welcome Josh, I’m glad it’s sorted 🙂

    igor
    igor
    Participant

    Hi Andy, i found the same problem to the grid alignment you can see here http://www.impresabarbiero.it/chi-siamo-2/

    where the last pic is aligned to the right and not to the left

    Could you please tell me where to add this code and if can resolve the problem?

    .gallery-wrap .two_column.columns:nth-child(2n+1),
    .gallery-wrap .three_column.columns:nth-child(3n+1) {
    clear:left;
    }

    Actually i added the code in Appearance > Theme Options > Customize > Custom CSS

    Thank you so much!

    Igor_

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.