Home / Forums / ePix Support / Grid Gallery always shows one less column than set, if done with Visual Compozer

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Tobias Jeschke
    Participant

    Hello,

    Thanks for the wonderful and rich theme!

    I did search the forum and the documentation and couldn’t find a solution to the following problem:

    Pages with a Grid Gallery show one less column than set, but only if done with Visual Compozer (!), regardless of browsertype or device used, if browserwindow is over 1200px. Everything under that size seems o.k. and everything above that windowsize shows one column less or (if the browserwindow is overstretched) an odd and really wide spacing (500-1000px) between the pictures in the grid.
    The opposite and ‘normal’ happens, if I set a grid and it’s columns with the “Add Gallery” feature of the Pagebuilder, everything is alright – meaning the right and set number of columns and no odd spacing etc.

    I tested this quite a few times with 3, 4, 5 columns and masonry and column padding on, pictures from slide manager set, no effects, no width or height restrictions, lightbox on, no other effects, wide layout and no custom css for the site.

    I understand that the ‘Add Gallery’ feature stretches the width of pictures to make the grid fit the screen, regardless of number of columns and the Grid Gallery via the Visual Compozer doesn’t. I also get, that the grid rendering (column number) with set columns depends on and relies upon or does vary with actual screen estate.

    1.Is this different behaviour between Visual Compozer and Add Gallery via normal Pagebuilder a bug and is there a workaround?

    2. What could be done to let use Visual Compozer generate the same output like Add Gallery?

    I wouldn’t use Add Gallery alone, because it’s more cumbersome, if one would like to add more content to the side above or beside the so added Grid Gallery.

    Many thanks and have a nice day


    Tom ( Support)
    Keymaster

    Hi Tobias,

    Thank you for your detailed questions, this helps a lot. Are you using the masonry effect on your grid galleries? Is your page set to wide or boxed?

    Do you have an example page of both of these galleries so I can take a further look into exactly what you mean? If you could please set your reply to private and provide your URL/login details so I can take a further look for you that would be a big help too.

    Kind regards,
    Tom


    Tobias Jeschke
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Tobias,

    Visual composer has a default width set of 300px which I did not know about. We have changed this to 500px within the options and it now displays the same as the page options grid gallery.

    Hope this helps.
    Tom


    Tobias Jeschke
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Tobias,

    It is effectively the max-width that has been set. So you can set this to 1000px wide if you liked and it would provide the same results as the page config grid gallery.

    Hope this helps.
    Tom


    Tobias Jeschke
    Participant

    Hi Tom,

    Thanks for your help and have a nic day

    Tobias


    Tom ( Support)
    Keymaster

    Thats great, thank you for coming back to us.

    If you are happy with the theme, please take a second to rate the theme 5 stars here.

    Much appreciated 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.