Home / Forums / DynamiX Support / Group Slider showing white space. Was working perfectly.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts

  • Mark Pendlebury
    Participant

    Hi everyone,

    I have a page with a group slider showing images from my category 'gallery'. There are about 24 images in this gallery and it works perfectly.

    However, whenever I want to add another image into this gallery now the image inserts but I am left with white space at the end of the slider. As though there are images there that I cannot see. Imagine scrolling to the very right and there is just white space rather than wrapping back to the first image.

    If you select the newly added image it opens in the Lightbox no problem and you can then scroll through all images in the lightbox and there are no blank images in here. As soon as I take the post of the 'gallery' category the slider is perfect again.

    I am using the same method to insert the image posts (as shown in the documentation video) and I don't think I'm doing anything different.

    Could this problem result from bad records in the database as I was having trouble uploading these images at first as my host went down.?

    The only thing I think is different is that I resized the images in Picasa as a group export whereas every other image I have posted so far has been resized in irfanview.

    I have removed all the posts that I have added for this, removed all the images from the library and tried again but to no avail.


    Mark Pendlebury
    Participant

    Long shot but does anyone think this could be a plugin issue? I'm going to deactivate the few I have added recently at lunch to see if it has any effect on posting.

    The thing that makes me say this I have a twitter plugin that allows tweeting from posts and this has created an option in my post creation. Worth a try I guess.

    An even longer shot is that if I ftp into my site directory at the same time as posting I can see where the images are uploaded to. For example all the working images are in /wp-content/uploads/2011/06/

    However, on occasion the post will be there and working (as a post but creating white space in the slider) but the actual file will not be present in the directory. Normally uploading creates 3 files. The original, a smaller one and a thumbnail size. If I then keep refreshing the directory the files will eventually show. But the slide is still showing white space.

    Bizzarre but it's really frustrating me. I have a couple of other sliders on my site (created using the shortcode generator) and it seems this whitespace behaviour has crept into them as well. 

    Any new image causes a problem in my sliders?!?!?

    Any advice welcome. Or just suggestions…….


    Mark Pendlebury
    Participant

    Further update, problem still exists after…

    1. Deactiving all plugins. 

    2. deleting all revision posts in the database

    3. as far as I can tell there are no duplicate image records

    4. I also changed the way the slider worked. Instead of making all images I want to appear in it members of the 'gallery' category I changed the slider to display gallery + other categories. This way I ensure that posts only live in 1 category.

    Basically, at the moment if I add a new image post and want it to appear in on my gallery page (where the slide gallery lives) I upload the image, place it in the required category and it appears in the slider if that category is turned on.

    Problem is any image I add creates a blank white space at the end of the slider. I have a couple of sliders on other pages and it's happening there as well. 

    Is there an image limit in a slider?

    Any ideas Andy or anyone?


    Anne LN
    Participant

    Mark, I had once the same problem and it was "white" for pictures which have a html link in video url.

    May be it can help you…

    Andy
    Andy
    Keymaster

    Hi Mark,

    The group slider will show blank spaces because you have 25 images and that doesn't divide by 3. 24 divides by 3 so you'll have 8 sets of 3 images. With 25 you'll get 8 sets of 3 and 1 set of 1. You would have to add two images to equalise it. 

    Hope that makes sense. 

    Andy


    Mark Pendlebury
    Participant

    Yes it makes perfect sense Andy! Simple really. And as soon as you said I had a DOH moment. Anyway, added more images this morning and ensured that the total is divisible by 3 and it's all hunkydory again.

    Thanks again for the great support and theme. I'll recommend it to anyone I know who needs one!!!

    On a side note I've got my slider working great but was wondering as to the advantages of having a slide set. I don't need people to be able to link or see the actual post just the image on display. Is this the main advantage?

    Although I do have images that appear in more than one gallery so would a slide set make this easier or more difficult to manage?

    I posted the site I've done on the main showcase group (philosophyflowers) so you could see what I had managed to do. Hope you like it.

    Andy
    Andy
    Keymaster

    Hi Mark,

    That's okay, happens to the best of us 😉 

    The slideset is a much easier way to manage the images yes it doesn't use posts so it doesn't link anywhere. Plus you can change the order etc easily. You can only select 1 slideset per gallery at the moment but that slideset can be used in multiple galleries. I am going to change this so you can selected multiple slidesets in the near future. 

    I'll check out the showcase later today, look forward to seeing it. 

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.