Home / Forums / ePix Support / Help on epix galleries & other issues

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Paolo Valentini
    Participant

    Hallo,
    first thing I’d like to thank you for the amazing work with epix.

    I am using the theme to display my photography portfolio.
    Unfortunately I am experiencing a few issues with the theme, I hope you can help me out.

    1. Whenever I upload new media (multiple images) I always end up with the following: Fatal error: Out of memory (allocated 51904512) (tried to allocate 4096 bytes) in /home/grigiomedio/www/wp/wp-includes/media.php on line 2043
    Tha media shows correctly but it’s still bothering.

    2. Very important: When I add images from the media library to the Slide Set Manager I cannot insert more than 79 pictures per set. Is there something wrong with my setup or should I just use multiple sets to create a gallery?

    3. In the grid style gallery, how do I remove the ‘alt’ (image name) thing on mouse over? I’d like to remove it as well in the lightbox.

    4. Whenever I install a new plugin or even theme updates I get the following error:
    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/grigiomedio/www/wp/wp-includes/update.php on line 119

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/grigiomedio/www/wp/wp-includes/update.php on line 295

    Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/grigiomedio/www/wp/wp-includes/update.php on line 457

    It looks like everything is working anyways. Should I be concerned?

    Thank you very much,

    Paolo Valentini

    Andy
    Andy
    Keymaster

    Hi Paolo,

    1. This sounds like your wordpress is running out of memory. You can try to resolve this by defining more memory in your /wp-config.php file. See the wordpress guide here.

    2. Unfortuantely the server can only handle so many images being saved at once. I recommend creating multiple slide set i.e. 01 Home Slide Set, 02 Home Slide Set etc. Then you can select as many as you wish.

    3. Which version are you using, this was removed in the latest, but a number of users have had an issue with this and I’ll be implementing back in. It is for accessibility purposes and the only way is to modify the core files.

    4. This sounds like your wordpress install maybe in need of re-installing. Are you using WordPress 4.1?

    Kind regards,
    Andy


    Paolo Valentini
    Participant

    Hi Andy,
    thank you for you quick reply.

    1. I’ll look into it
    2. Ok, multiple slide sets then
    3. I’m using the last version. I didn’t check ‘alts’ after the upgrade. It looks like they have disappeared now. Great!
    4. I’m ruuning wp 4.1. I tried to reinstall from the admin panel but got the same errors. Sigh.

    Paolo.

    Andy
    Andy
    Keymaster

    Hi Paolo,

    Did you try increasing the WordPress memory and did it resolve the other issue.


    Paolo Valentini
    Participant

    Hi Andy,

    I looked at the guide but I can’t find the lines to change in wp-settings.php
    Paolo.

    Andy
    Andy
    Keymaster

    Hi, It should be in wp-config.php. Add something like

    define( 'WP_MAX_MEMORY_LIMIT', '256M' );


    Paolo Valentini
    Participant

    Hi Andy,
    I think I solved most of my issues with the theme and I’m finally online: http://www.grigiomedio.net
    I’m running 1.4 as of now.
    The only thing still bothering me is the “alt” filename in the grid picture galleries.
    Could you help me out to remove it?
    Thank you,

    Paolo.

    Andy
    Andy
    Keymaster

    Hi Paolo,

    It’s real awkward one. I removed it in the previous version and then I had users complaining that it didn’t have an alt tag and equally I have users who want it removed.

    So, I’ve come up with a bit of javascript for you. Please place this into Appearance > Theme Options > Customize > Javascript:

    <script>
    jQuery(document).ready(function($) {
    $( 'a.fancybox' ).each(function( index ) {
    $(this).attr('title','');
    });
    });
    </script>


    Paolo Valentini
    Participant

    Brilliant!
    It works.
    Thank you so much!
    Paolo.

    Andy
    Andy
    Keymaster

    You’re welcome Paolo!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.