Home / Forums / DynamiX Support / Help please – Updated my Themeforest theme and the site has totally messed up!

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • Steve Slimm
    Participant

    Hi,
    I’ve been really pleased with the Themeforest theme I purchased – but when I came to update a page today the visual composer wasn’t functioning. I updated the VC and still not working. I then updated the theme itself and it has totally messed up the site, and nothing works!

    I get several hundred hits a day, and don’t want this to continue long.

    My site is steveslimm.com – please help.

    Thanks,
    Steve :((


    Steve Slimm
    Participant

    this is the message that comes up on the only readable page:

    Fatal error: Call to undefined method WPBakeryShortCode_VC_Row::getShortcode() in /home3/idlum7/public_html/wp-content/themes/DynamiX/vc_templates/vc_row.php on line 163

    Thanks.

    Steve


    Steve Slimm
    Participant

    I have cleared the cache in the browser and flushed the computer – I think the first possible solution is for me to be able to update VC – as it’s still showing an older version (4.4.2) , but also tells me elsewhere that it’s up to date.

    S

    Hi @idlum7

    What version of the theme are you currently using?

    Also, can you send over your login credentials so we can check on this further?

    Regards,


    Steve Slimm
    Participant
    This reply has been marked as private.

    Hi @idlum7

    We checked your WP Dashboard and you are still using an older version of Visual Composer. Kindly update the Visual Composer to its latest version as the new version has bug fixes for WordPress 4.5.

    Regards,


    Steve Slimm
    Participant
    This reply has been marked as private.

    Steve Slimm
    Participant

    All working again – thanks.
    I kinda wish I’d have spotted the need to purchase VC before signing up to a further six months support with you! But who knows I might need you more yet.
    It’s a great theme – and Visual Composer makes it a real treat to edit etc.

    Thanks,

    Steve
    😉

    There was actually no need to purchase Visual Composer. The new version of the theme came with an updated version of Visual Composer and all you needed was install it via ‘Theme Options’ > ‘Install Plugins’.

    Regards,


    Steve Slimm
    Participant

    Hi,

    I had tried that – three times actually. I clicked on’ update’ – it went through the process, said it was all done – then still showed the older version in the version box – saying there was a new one available. Something was obviously wrong with the system.

    Anyway, it won’t hurt to own the plugin properly, and have updates as they come out. I din’t mind spending a bit to smooth the way. I shall probably buy the revolution slider too, so I can have updates as they come out.

    I think problems tend to come with an update of WordPress, which then throws up idiosyncrasies and anomalies in the themes and plugins. But you’ve probably sussed that years ago!

    Thanks for your assistance – and I might need more with the themes – as I also have another from you, which I’ve not got too much into using yet.

    Best to you,

    S


    Steve Slimm
    Participant

    Hi again,
    I’m afraid there’s still a couple of probs with the functioning of the site. I’m not sure what they relate to:

    1) A Search box has suddenly appeared, which obscures some of my menu. How do I get rid? Search is not showing as an active widget.
    2) The top row of the menu no longer links to the relevant pages – they are not clickable. The sub-menu items are fine.

    Can you advise please?

    Thanks,

    Steve
    🙂
    p.s.
    I have further discovered that if I make the page either significantly bigger or significantly smaller, (by dragging my fingers across the pad), when the search box is sufficiently removed from the menu, all the top row links work fine! Which seems to suggest the whole problem is about having the search box appear.

    • This reply was modified 10 months ago by  Steve Slimm.

    Hi @idlum7

    I have fixed this for you. Please check.

    Regards,


    Steve Slimm
    Participant

    Hi –
    yes the Search box has gone now – thanks!

    Steve
    😉

    You’re welcome.

    Don’t hesitate to contact us if you encounter any issues.

    Thanks!

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.