Home / Forums / DynamiX Support / How to save widget changes in Customizer

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • Katie Keith
    Participant

    Hi, my client has found that he can’t save changes to widgets in Customizer. He is trying to change the Northvantage Widget Gallery to display Post Categories and to select a category. When we select ‘Post Categories’ and tick a category, a loading icon appears at the bottom of the screen forever and there is no ‘Save’ option. We can’t click the ‘Save’ button at the top of the page as it is greyed out.

    Screenshot available at: http://with-omraam.com/wp-content/uploads/2015/07/wIDGET.png

    How can we edit the widget?

    Many thanks

    Andy
    Andy
    Keymaster

    Hi,

    I’ll investigate this. For the time being, please use Appearance > Widgets instead to edit the widget.


    Katie Keith
    Participant

    Hi, I have tried editing the widget in Appearance > Widgets and that is buggy too. If I select several post categories on the NorthVantage Widget Gallery widget and click ‘Save’, my selections often aren’t saved. What’s happening?

    Many thanks

    Andy
    Andy
    Keymaster

    Hi Katie,

    It sounds like a plugin conflict. I’ve tested on my servers and it doesn’t appear to experience this issue. Please try disabling all plugins apart from the Visual Composer to see if it then works. If it does, please enable the plugins one-by-one to see which one is causing it.

    Failing that, please post your WP login details and I’ll take a look for you.


    Katie Keith
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi,

    I’ve just tested this with the Sidebar one width, I’ve selected Multiple Slide Sets and it’s saved and functioning on the front end.

    What browser are you using, I recommend using Chrome if you’re not already.

    I’ll change it back to Media Categories.


    Katie Keith
    Participant

    Hi, it is definitely not working in Firefox or Chrome. You can see a screenshot of the problem at: http://screencast.com/t/K8uA1QeA1

    In this screencast, I repeatedly select multiple categories and then click Save and it immediately loses some of my selections.

    Many thanks

    Andy
    Andy
    Keymaster

    Hi,

    I’ve managed to replicate on your server now, it’s your category slugs. They do not all match their name. e.g.

    An Alternative Paradigm should have a slug of an-alternative-paradigm

    Instead is has: paradigm


    Katie Keith
    Participant

    Thanks for your reply. Why do the slugs have to match the name? The list of available categories displays using their names and doesn’t mention the slugs.

    Surely this is a bug with the theme and I should not have to rename all my category slugs?

    Many thanks

    Andy
    Andy
    Keymaster

    Hi Katie,

    It should have been implemented to store ID’s of the categories originally and not the names. However, when developing it over 5 years ago, it was a method that wasn’t thought through completely ( slug vs name mismatch for example ) and ended up having to stick with it because if I change to ID’s now, when a user updates, they’ll lose all their category settings.


    Katie Keith
    Participant

    Ok, thanks very much


    Katie Keith
    Participant

    Sorry, this still isn’t working. I renamed the category Aura, Yoga & Chakras to aura-yoga-chakras and tried to select this category in the gallery widget, and my selection still isn’t being saved.

    Many thanks

    Andy
    Andy
    Keymaster

    Hi,

    It’s because the Category name has a comma and & character in the name. If it were named Aura Yoga Chakras it would work. Or if you wanted the “and” you could have “Aura Yoga and Chakras” => “aura-yoga-and-chakras”


    Katie Keith
    Participant

    Thanks very much

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.