Home / Forums / DynamiX Support / image auto zoom/crop doesn’t work after Update 2.8.1 to 2.8.6

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • HammeR
    Participant

    Here is an example: http://www.360weggis.ch/rubrik/dienstleistungen/sonstige-dienstleistungen/gemeindeverwaltung-weggis/

    When I activate the theme to 2.8.1, it is OK.

    Is this a bug? an idea? Original Image is 1024x902px

    Thank You,

    Daniel

    Andy
    Andy
    Keymaster

    Hi Daniel,

    Is it just the blog pages that are not working? It looks like it's not accepting the zoom value – if you can confirm whether it's working okay with galleries etc we'll go from there. 


    HammeR
    Participant

    I think there's a problem with TimThumb?

    /wp-content/themes/DynamiX/lib/scripts/cache folder has no images only new txt Files? cache Folder Permission 755 and test 777.

    I test a Gallery Slidesets, I only seer thumbnail.

    http://www.360weggis.ch/wp-content/themes/DynamiX/lib/scripts/timthumb.php?h=&w=&zc=0&src=/wp-content/uploads/2011/05/gemeindeverwaltung_weggis_2.jpg

    What is the problem?


    werez
    Participant

    I've had the same issues and nothing could solve it, so I just hardcoded chosen timthumb parameters and finally my galleries started looking right.

    if(!get_option('timthumb_disable')) { // Check is Timthumb is Enabled or Disabled

        $DYN_imagepath = get_bloginfo('template_directory')."/lib/scripts/timthumb.php?h=". $DYN_postimgheight ."&w=". $DYN_postimgwidth ."&zc=1&a=c". $DYN_imgzoomcrop ."&src=";

    } else {

        $DYN_imagepath="";

    }


    HammeR
    Participant

    Is this a bug?

    @andy you have any idea what's wrong here?

    Andy
    Andy
    Keymaster

    It looks like a bug – I'll look into this today and place into the next update. (if it's an easy fix I'll place it here as well. )


    Semih Sevinc
    Participant

    Hello,

    I ran into the same issue with 2.8.7

    I noticed that everything works fine with Accordion galleries, but all other gallery types show stretched images with wrong aspect ratio regardless what crop setting.

    Now, when I tried to use a Stage Gallery I found that the image URLs (using timthumb) were missing the height parameter:

    […]/themes/DynamiX/lib/scripts/timthumb.php?h=&w=940&zc=1&src=/wordpress/wp-content/uploads/[…]

    In "Add Post / Slide Set Gallery" -> "Additional Setting (All Galleries)" there is an optional setting for image height.

    …at least I thought it was optional: no default value is applied to the URL image height parameter if this setting is left empty. As soon as I entered the "default" value "350" into this field and updated the page, everything looked fine.

    It seems like it's just a matter of providing proper default values to the image URL generator in case the setting remains empty.

    Keep up the good work,

    Semih

    Andy
    Andy
    Keymaster

    Hi Semih,

    Ok I'll take a look to why the default value isn't being added. This is the same for all galleries is it? 


    Semih Sevinc
    Participant

    Hi Andy,

    thank you for your quick answer. I examined only the Stage Gallery yesterday.

    I took a closer look at the other galleries now and it seems that only Stage Gallery and 3D Gallery are affected. Grid Gallery and Group Slider seem to be ok (although I did not try every combination of gallery type and crop option).


    Edit: I had a look at the URLs being generated for 3D Gallery now, there is a different mistake: the "zc" parameter that determines timthumb's zoom option is not filled with numbers ("0", "1", etc.) but with the option text, e.g. "zoom" which also leads to incorrect aspect ratios. The default values for width and height are properly applied for 3d galleries.

    An example:

    […]/wordpress/wp-content/themes/DynamiX/lib/scripts/timthumb.php?h=350&w=940&zc=zoom&src=/wordpress/wp-content/uploads/[…]

    regards,

    Semih

    Andy
    Andy
    Keymaster

    Thanks Semih, I'll take a look as to why it's not converting the zoom value into a integer. 

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.