Home / Forums / DynamiX Support / Image behind the Disqus comments count on my WordPress blog

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts

  • Vipin Ramdas
    Participant

    Hi everyone,

    I just installed Dynamix 3 on my blog and I seem to have a wierd problem with the comments count. Disqus shows some sort of an image behind the comments count for each post. Its the same image. Here is alink to my website. http://www.vipinramdas.com.

    If I switch off Disqus the normal WordPress commenting system works fine so I know this is something to do with Disqus. However Disqus worked fine with my previous template.

    When I looked at the element it shows the following <span class = “dsq-postid” rel= “187 http://www.vipinramdas.com/?p=187” No Comments /<span>.

    Any help would be appreciated


    Tom ( Support)
    Keymaster

    Hi Vipin,

    It appears to be working fine, I cannot find an issue with the comment count. I might be missing something so could you provide me with a screenshot so I can see exactly what the problem is?

    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Hey Tom

    Thanks for that. I was trying a few things to fix it as a workaround and it seemed to work. But it took away the text and only left the comment bubble. I have put it back to what it was. You should now see the problem.

    Thanks


    Tom ( Support)
    Keymaster

    Hi Vipin,

    I am still not sure as to which part of the theme you are talking about? Please provide a screenshot so I can see exactly what you are referring too.

    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Hi Tom,

    How do i upload the screenshot?

    Cheers


    Tom ( Support)
    Keymaster

    Hi,

    You can use any photo upload site like photobucket for example.

    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Here is the screen shot
     photo disqusissue_zpsff37defe.png

    If you visit my blog section here you will see the issue


    Tom ( Support)
    Keymaster

    Hi Vipin,

    Ok great thanks for that. Andy has come up with a fix for this. Please add the following CSS code into the Custom CSS field under,
    Appearance > Theme Options > Customize > Custom CSS.

    .dsq-postid {background:none !important;}
    

    Hope that helps.
    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Hey. Thanks for that. That resolved the issue with the image. However the “No comments” text shows on 2 lines and is eating up unnecessary space. Any help with that. You can refer to the same screen shot


    Tom ( Support)
    Keymaster

    Hi Vipin,

    Please add the following code under the previous code in your Custom CSS field.

    .dsq-postid {
    white-space: nowrap;
    }

    This should set it to just one line.

    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Hi again,

    Thanks.That fixed the issue on the blog page. But that has developed a problem on the single post page. The comments section overflows into my sidebar now. See screen shot below

     photo singlepost_zpsced52db8.png


    Tom ( Support)
    Keymaster

    Hi,

    Try the following code in your Custom CSS field.

    .post-titles ul.post-metadata-wrap li.comments-list, .post-titles ul.post-metadata-wrap li.edit-link {
    margin-right: 50px;
    }
    

    Kind regards,
    Tom


    Vipin Ramdas
    Participant

    Hi
    Nope. That dint help. No change at all.
    Cheers
    V

    Andy
    Andy
    Keymaster

    Hi Vipin,

    Replace:

    .dsq-postid {
    white-space: nowrap;
    }

    with:

    .dsq-postid {
    width: auto !important;
    }


    Vipin Ramdas
    Participant

    Yup. That did the trick. Thanks Guys!!
    Great Support!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.