Home / Forums / DynamiX Support / Image Path, XAMPP

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Pat
    Participant

    Hi Guys,

    i have a Problem with the Image-/ Video Paths on XAMPP (My WP Version: 3.3.2).

    For Example:

    When i given in the short Path: /wp-content/uploads/2012/04/sunbird.jpg -> Image not  display on the Page.

    When i given in the full Path: http://localhost/_Dynamix_Test/wp-content/uploads/2012/04/sunbird.jpg -> Image display on the Page.

    When i type in the short Path, i don't have a Image in the Cache.

    When i type in the full Path i have an Image in the Cache.

    Need the System for a local installation the full Image-Path?

    The Theme is correctly install: All of this theme’s files are located in /themes/DynamiX

    Thank's for Answer….

    Greets Pat


    keyhanjun
    Participant

    Try this:

    http://stackoverflow.com/questions/7823260/xampp-relative-urls-not-working-correctly

    Please report back if it works for you. 😉


    Pat
    Participant

    thanks for the Link 🙂

    sorry, dosen't work – become a 500 Internal Server Error back, wp-admin-login and frontend.  I set C:/xampp/htdocs/_Dynamix_Test/ as DocumentRoot in the httpd.conf File, but not work.

    After this Changes are localhost/wp-admin/ & http://localhost/index.php the correctly Paths, right?


    keyhanjun
    Participant
    Before you can edit the httpd.conf file you have to go to the WP backend to avoid the 500 error:

     

    "Settings/General Settings" & fix:

     

    1. WordPress Address (URL)

     

    2. Site Address (URL)

     

    Here is an example of my XAMPP setup (WP installed in a subfolder).

     

    My file structure is:

     

    C:/xampp/htdocs/wordpress/wp-content/themes/DynamiX

     

    1. So first I logged into the backend of WP & changed the settings under "Settings/General Settings"

    from:

    WordPress Address (URL) = http://localhost/wordpress

     

    Site Address (URL) = http://localhost/wordpress

    to:

     

     

    WordPress Address (URL) = http://localhost

     

    Site Address (URL) = http://localhost

    2. closed the browser & the XAMPP server

     

    3. opened the file:

     

    C:xamppapacheconfhttpd.conf

     

    & edited the line:

     

    C:/xampp/htdocs

     

    to:

     

    C:/xampp/htdocs/wordpress

    4. started the XAMPP server again & loged in WP again

     

    >>> Now everything works like a charm. No 500 errors anymore and you can use relative paths like:

     

    /wp-content/uploads/2012/04/sunbird.jpg

     

    Hope this helps. 😉

    Pat
    Participant

    works 😉

    Thank you for help! I'm happy now 🙂


    keyhanjun
    Participant

    Glad it worked out for you! 😉

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.