Home / Forums / DynamiX Support / Incorrect Post Title Showing

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Will Watrous
    Participant

    On our sites we have often used a plugin called WPMapFolio that displays information on several of our client’s projects in a series of custom post types. We have a problem on the last few sites we’ve done with Dynamix in that the incorrect post title is being displayed for the H1 tag. It’s the same title on every post. We contacted the plugin author and he says it’s the theme. I have a test site set up and the plugin works on the twentyfourteen default theme, but breaks when we use dynamix. If you have any ideas on what is wrong please let us know. I’ll put the site & login information in a private post under this. It’s a bare-bones setup without the rev slider & visual composer installed as it is only for testing purposes.


    Will Watrous
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Will,

    Thank you for the detailed information. I will ask Andy (theme creator) today and get back to you ASAP.

    Kind regards,
    Tom


    Tom ( Support)
    Keymaster

    Hi Will,

    I have asked Andy about this and we are really not sure where the title is coming from. Please can you provide your FTP details and we will take a further look into this.

    Kind regards,
    Tom


    Will Watrous
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi Bex,

    Thank you for this, Andy (theme creator) is looking into this and will get back to you by this time tomorrow.

    Kind regards,
    Tom


    Will Watrous
    Participant

    Thanks. I appreciate it.

    Andy
    Andy
    Keymaster

    Hi Will,

    I’ve managed to get to the bottom of it. Because of the nature of the theme and way it pulls in the post data, the plugin was somehow distorting the ID and pulling in a title from another post. I’ve modified one of my files ( in case someone else ever does this ) to make a backup of the original post in question and re-assign it after it’s applied the wordpress filter to it.

    The file that has been modified is the DynamiX/lib/inc/classes/blog-class.php ( you’ll find it on your test server ).

    I hope that helps?


    Will Watrous
    Participant

    Awesome. Works like a charm. Will this fix be a part of the next dynamix update or do I need to make sure I keep a copy of the file?


    Tom ( Support)
    Keymaster

    Hi Will,

    This will be a part of the next update 🙂

    Thanks,
    Tom

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.