Home / Forums / You Theme Support / Legacy Content Appearing

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts

  • sandwichmike
    Participant

    Hi

    I am building duplicate pages for multiple languages and have a strange issue

    I used polylang for the language plugin and a Duplicate Page plugin to generate the content from my original page.

    When the language is automatically detected, the second translated page shows fine, but when the language is selected from the dropdown instead, the translated page adds to the bottom all the other content previously deleted, the original example skin text, deleted content, draft content from other pages.

    I can’t send you the link to see the content as I clearly haven’t published that page, but can send you login info privately if you need to see the issue

    Thanks

    Hi @mikemckie

    Please send your site’s URL and login credentials so we can personally check and test on this further from our end?

    Regards,


    sandwichmike
    Participant
    This reply has been marked as private.

    Hi @mikemckie

    I checked your Dashboard and was able to see the Skin Content when editing the page. Can you please send a screencast so we could check on this further as everything looks perfectly fine from our end?

    Regards,


    sandwichmike
    Participant

    How do I attached screencast or screengrab files to this forum please?

    Hi @mikemckie

    You can upload your screenshots here https://prnt.sc/ then send us the URLs so we can check.

    Regards,


    sandwichmike
    Participant
    This reply has been marked as private.

    Hi @mikemckie

    I checked and tested your site and was able to see now the issue. Can you please grant us permission to disable all plugins to check further on this?

    Regards,


    sandwichmike
    Participant
    This reply has been marked as private.

    Hi @mikemckie

    I think the root of the issue is how the translation page is created/connected with each other.

    Here is what I did:
    – I duplicated your homepage to create this test homepage: http://www.sandwich-craft.com/home-3-4/
    – After doing so, I clicked on the + icon for the Spanish column of the page which opened a page editor.
    – I then pasted the Spanish version of the page to the editor and saved it http://www.sandwich-craft.com/es/test-home-es/

    If you test switching back and forth between the Spanish and English version of the page I created, you will not see the issue

    Regards,


    sandwichmike
    Participant

    Thanks Edcel – seems to have cured THAT issue, but another has arisen, maybe something to do with what you have done with plugins….

    Now the “Static Front Page” setting won’t save and hold and the site automatically reverts back to “Posts” – so neither of the home pages are available to visitors.

    No idea how to solve this

    Hi @mikemckie

    This error actually appears when you set Static Front Page:
    “The chosen static front page must be translated in all languages.”

    Please translate the homepage to all languages you have added so far for it to work.

    Regards,


    sandwichmike
    Participant

    Great – finally solved – many thanks for your determination to solve this!

    You’re welcome, @mikemckie

    Please don’t hesitate to contact us back if you encounter any issues.

    Regards,

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.