Home / Forums / ePix Support / Menu links broken on mobile

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • Ryan Moyer
    Participant

    Since the latest wordpress/epix update, menu links no longer work on mobile.

    My site is: http://ryanmoyer.com

    If you click one of the menu links on mobile it just goes to http://ryanmoyer.com/#

    Additionally, while clicking the links works on desktop, hovering over them to see the sub-menus no longer does.

    Hi @moyer921

    Can you please over your site’s login credentials so we can check if you are using the updated version of the theme and Visual Composer?

    Thanks!


    Ryan Moyer
    Participant
    This reply has been marked as private.

    Hi @moyer921

    I checked your WP Dashboard and it shows that you are using an older version of Visual Composer. If you are unable to update it, you may have to deactivate then delete. Once deleted, try to reinstall it.

    Regards,


    Ryan Moyer
    Participant

    Hi Edcel,

    I’ve upgraded to the latest version of visual composer however the problems remain.

    Hi @moyer921

    I checked your site and the menu is working fine. Can you clear your browser cache and recheck?

    Thanks!


    Ryan Moyer
    Participant

    Yeah I’ve cleared my browser cache and still see the issues.

    To be clear, when you say it is “working fine”, you’re able to click the links on mobile, and on desktop you’re able to hover over the menu options and have the sub-menus drop down? For instance when you hover over “Galleries”, do you see the galleries sub-menu drop down?

    Hi

    For menus with sub items, for the drop-down to work on mobile, the main menu content should only be an anchor and not an actual link. So that you will see what we mean, we have updated the ‘About’ menu. We replaced the actual URL to a ‘#’ sign and that fixed the issue.

    Regards,


    Ryan Moyer
    Participant

    I believe you are misunderstanding the issue. I do not need the drop-downs to work on mobile. There are two separate issues, one on mobile and one on desktop.

    Issue #1) On mobile, the menu links do not work at ALL. Here is what I see, at least in my chrome mobile browser, when I load up the website.

    If I click the 3 bars icon at the top, or the search button, or any of those buttons, this is what I get.

    Essentially, nothing happens. I cannot browse the menus at all on mobile. I had someone else try on their iphone as well and they had the same issue.

    Issue #2) On desktop, the drop-down menus on hover do not work.

    So if I go to ryanmoyer.com, and hover my mouse over the “galleries” link.

    What should happen: The galleries sub-menu should drop down and show options like “nightscapes”, “landscapes”, etc.
    What actually happens: Nothing

    Are both of these things working for you? On what browsers? I have tried chrome and firefox on desktop (with cache cleared) and chrome mobile and safari on mobile.

    • This reply was modified 1 year, 1 month ago by  Ryan Moyer.

    Hi

    I checked again your site both on desktop (Firefox and Chrome browsers) and mobile (Safari and Chrome) and the menu is working. See the screenshots below:

    Mobile = http://i67.tinypic.com/2nqy92g.jpg
    Desktop = http://i64.tinypic.com/11w8yzd.jpg

    Regards,

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.