Home / Forums / DynamiX Support / Menu Not Clickable / Jigoshop

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts

  • Christopher Padilla
    Participant

    Hello,

    I just started an install with the theme and using Jigoshop e-commerce plugin. None of my menu items are clickable (you can click them but they go nowhere, however the correct address does display at bottom of firefox). By the way, im using a "custom" menu and i did select it in dynamix options. The menu was not clickable (you can click it, it just won't go anywhere) even without using the custom menu. I tested it with other themes and the menu works fine.

    I've yet to do any custom CSS for the site, nor properly integrate the "shop" page with the theme so the layout is messed up for now.

    Anyways is there an easy fix I can apply to make the menu items function when you click them?

    You can see what I mean here: http://www.hyestpc.com/anasazigold

    Any help would be appreciated!

    Chris


    Christopher Padilla
    Participant

    I could have sworn I made it work in firebug by changing the z-index to 1 of this property:

    #tabs #dropmenu, #dyndropmenu {

        z-index: 1 !important;

    }

    I went in to add it to the header and it didn't work, nor did it work in firebug again. I'm sure it's a conflict between the theme and jigoshop because when I disable jigoshop it works. I think jigoshop uses the css class "#tabs" as well, however I still can't figure out where the problem is deriving from or what to change.

    Thought i'd add this in case it helps any troubleshooting

    Andy
    Andy
    Keymaster

    Hi Christopher,

    I'm pretty stumped on this one too – there doesn't appear to be any conflicts, including CSS. The only thing I can think of is something in there Javascript is stopping the links from working. It maybe worth contacting the developers to see if anyhting in there JS would cause #tabs to stop working.

    Just check as well that re-saving the permalinks doesn't solve the issue?


    Christopher Padilla
    Participant

    I've tried just about everything I could think of and could not get the menus to be clickable, which is obviously a  huge part of a website


    Harald Kalasek
    Participant

    Hi there,

    I had the same problem with jigoshop; now I´m using the shop from tribulant and I have this problem with the images. If a user klicks on them, they won´t open.

    If you do a right-click and say "open in a new window", all links are working. its the same error as on your site.

    I know, this is not a solution, but it may help Andy to find and fix this error.

    harald

    Andy
    Andy
    Keymaster

    Christophher did you contact the plugin developers and ask them regarding the #tabs? 

    It seems to be a javascript issue – the only thing that would cause it to stop working. Even in your case Harald. 

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.