Home / Forums / DynamiX Support / Metadata problems

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Pavel
    Participant

    Hi,

    there are some problems with metadata-class.php:

    1) It is not possible to set our date and time settings, please make it localizable or use standard WordPress settings.

    2) It is not possible to turn off links to daily/monthly archives, we need only simple text and do not want to show and index archives. It could be also part of localization.

    3) “Comments”, “No Comments”, etc are shown even if comments are not allowed. So, people can click on “No Comments” link and there is no form for comments. It is strange and it should be based on Post settings.

    Andy
    Andy
    Keymaster

    Hi Pavel,

    1) I’m going to change to the WordPress settings, the only part I can’t change is the date which displays as a square to the left of the post.

    2) I’m not sure where you mean for this, do you have a link example?

    3) Thanks for bringing this to my attention, I’ll hide the comments area is comments are disabled.


    Pavel
    Participant

    Hi,

    thank you for your answer!

    ad 1) Maybe localizable date settings are better than WP standard, users could want to display different date format in theme and in WP admin.

    ad 2) I talked about metadata-class.php, for example line 14:

    There is link which leads to: <?php echo get_month_link(get_the_time('Y'), get_the_time('m')); ?>
    But we would like to show date only as a simple text, without links to monthly archives.

    Andy
    Andy
    Keymaster

    Hi Pavel,

    I’ve decided to remove the date link completely and replace the date with a localizable date instead.

    Locate this file:

    DynamiX/lib/inc/classes/metadata-class.php

    Unzip and replace with:

    http://help.themeva.com/tmp/metadata-class.php.zip


    Pavel
    Participant

    Hi, dates were fixed in 3.1, thank you!

    But there is still link to comments, even if comments are disabled for particular post?


    Tom ( Support)
    Keymaster

    Hi Pavel,

    Andy will look into this and provide a fix tomorrow.

    Kind regards,
    Tom

    Andy
    Andy
    Keymaster

    Hi Pavel,

    I’ve created a new metadata-class.php file which addresses the comments icon, it now hides when comments are disabled.

    Locate this file:

    DynamiX/lib/inc/classes/metadata-class.php

    Unzip and replace with:

    http://help.themeva.com/tmp/metadata-class.php.zip


    Pavel
    Participant

    Perfect, thank you! Works well…

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.