Home / Forums / ePix Support / missing author information in microformat data

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author

  • David Kliewer

    Dear ePix authors,
    First of all, let me thank you for an outstanding piece of work you have crafted with this theme. After over one year, I am still happy with my site and it keeps evolving. In fact, I learn something new about the theme and the features brought to it by VC almost every week.
    One thing came to my attention and that is a piece of missing information in the microformats data used by google. The google search console’s structured data tool is showing errors for all pages that are category based, i.e. http://klwr.de/blog/category/fotografie/ to give an example. While entry-title and updated are existing, author is not implemented. A suggested fix for that would be to create a span containing the info within the div that produces the block on the archive page.
    Do you think you can include this in one of your next releases? It would certainly help many users to get their structured data clean (which could also have a positive effect on the rank as well).

    Kind regards,

    David Kliewer

    Dear ePix authors,
    After writing my post, I thought it would be strange if you really hadn’t thought of that so I dug into the code and saw that you in fact did add the author information, but only if the setting for author bio is activated not only on posts but also on pages. I think this is great news because you do not have to change your code, however, I never fully understood what this checkbox meant until now (and now it seems to obvious because the blog archive is in fact a page and not a post).

    So I am leaving this here to raise awareness for others – in case your google search console shows microformat errors for the hentry author, just make sure that in the theme options’ General Tab > Show Author Bio is set to Posts & Pages.

    Have a good day everyone.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.