Home / Forums / You Theme Support / Mobile Format is not showing all content

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts

  • enochbenjamin
    Participant

    When you view my site http://www.ebrochester.com on a laptop or desktop it seems ok, however on a mobile device it renders the pages almost useless with content clipped and flex shapes in random places. Please advise.

    Hi @enochbenjamin

    Can you please send over your login credentials so we can personally check on this further from our end?

    Regards,


    enochbenjamin
    Participant
    This reply has been marked as private.

    Hi @enochbenjamin

    I checked your site and I do not see any issues. Your site seems to be working perfectly.

    If you could send screenshots on the issue, we would appreciate it.

    Regards,


    enochbenjamin
    Participant

    How can I send you a screenshot?

    Hi @enochbenjamin

    You can upload your screenshot via https://prnt.sc/ then send the URLs so we could check.

    Regards,


    enochbenjamin
    Participant

    Thanks.

    You can view the mobile screenshot here: https://prnt.sc/g3k100

    Hi @enochbenjamin

    The content on the first row is clipped because there’s too much content and it wont fit on the display’s full height.

    This also affects the flexishape since it was designed to appear at the bottom of the device’s viewport.

    There are a few workarounds you can apply. Copy and paste this CSS into Theme Options > Custom CSS > Mobile CSS:

    .frontpage-top-row section.vc_cta3-container.vc_cta3-size-md {
        width: 100%;
    }

    It will help increase the width of the area where that red-bordered box is. You can minimize the spaces of this row further to fit them in the view port.

    You can add this CSS further to hide that stray flexi shape on mobile devices. Once again, copy it to Theme Options > Custom CSS > Mobile CSS:

    .frontpage-top-row rect {
    display: none;
    }

    Regards,


    enochbenjamin
    Participant

    This is becoming frustrating – neither of the workarounds helped. On mobile devices user are complaining that content is clipped and they cannot even see the forms on the page. This is getting critical as I have an event that people are trying to sign up for. In a desperate attempt to get things working i deleted the flexishape – but now i just have content clipped without triangles all over the place. Please help I must get this resolved soon!

    Hi @enochbenjamin

    Content will get clipped because there is only so much content a device’s viewport can display BUT they will still display when you scroll down. I added the CSS to adjust the elements on the first row.

    For the second row, again, the forms are not displayed right away because there is too much content above it, that is why you need to scroll down to see the form. I added another set of CSS to decrease the top padding of the second row.

    If your main issue is that not all contents are displayed right away on the devices’ viewport and you need to scroll down to see the content, this is a limitation on the mobile device and not with the theme. Again, there is just so much content a device’s viewport can display.

    Can you please send screenshots of how the issues with the site look from your end?

    Regards,

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.