Home / Forums / ePix Support / Mobile Menu Opacity

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts

  • Tim Hensel
    Participant

    Hi there

    I’ve tried searching but can’t find an answer in the existing forum posts.

    Is there a way I can change the opacity of the menu on the mobile version without affecting the desktop version of the site?

    My site is at https://www.timhenselphotography.com – the translucent menu looks great on the desktop but makes it hard to read on the mobile version.

    Many thanks

    Tim

    Andy
    Andy
    Keymaster

    Hi,

    Sure, try adding this bit of CSS into Appearance > Theme Options > Customize > Mobile CSS:

    .skinset-header.nv-skin {background-color:rgba(255,255,255,0.9) !important;}


    Tim Hensel
    Participant

    Thank you.

    Is it possible to use a floating menu on desktop and a standard one that sits above the content on mobile?

    Andy
    Andy
    Keymaster

    You could try the following in Mobile CSS:

    #header-wrap {position:relative !important;}

    This will push the content down.


    Tim Hensel
    Participant

    Thank you, that’s great.

    A similar question, but the opposite: on the desktop there’s a white gap at the top of my site, above the content. How can I get rid of this?

    Have a look at https://www.timhenselphotography.com

    I’ve tried setting the padding etc on the rev slider and the row it’s in to 0, but no dice.

    While I’m here, is there a shortcode to get the social icons to appear in colour instead of grey? I’ve tried setting this in the theme options. Look at the very bottom of the homepage. I’ve installed them there individually with the social icons thing in VC.

    Many thanks

    Tim


    Tim Hensel
    Participant

    Hi there

    I tried that code in mobile CSS, but it pushed everything including the menu down, leaving a white gap at the top. Removing the code won’t make it go away – I tried clearing the cache etc.

    Andy
    Andy
    Keymaster

    Hi Tim,

    The white space doesn’t occur on the standard setup. it looks like it might be being caused by a plugin or script entered into Appearance > Theme Options > Javascript.

    If you’re still having issues finding it, please post your WP login details.


    Tim Hensel
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Tim,

    It was a combination of things.

    1. The pixel image for tracking was causing some of the space.
    2. I had to addno-margin-top to the classes field of the row that contains the revolution slider.

    I hope that helps?


    Tim Hensel
    Participant

    Brilliant – thank you.


    Tim Hensel
    Participant

    Hi Andy

    A while ago you fixed this white space problem for me on my homepage.

    I seem to have it on my gallery page now. I’ve tried the same fixes that worked for the home page but it’s still there. You mentioned a tracking pixel might be partly to blame before, but I can’t find how to move/remove this.

    Please could you have a look for me? You’ve still got my login detail I expect.

    Many thanks

    Tim


    Tim Hensel
    Participant

    OK no worries, I’ve done a quick and dirty fix. I created a new page and put the revslider in that instead and it works fine….

    Thanks anyway!


    Tim Hensel
    Participant

    Hello again

    OK This one has me foxed once again.

    This is for a site I’m building for a friend, http://thornsettfieldsfarm.co.uk

    If I put the no-margin-top class name in, or put 0 in the margin or padding etc, it makes the gap at the top bigger rather than removing it. It’s at it’s smallest if I just put the shortcode for the rev slider into the page, as soon as I use a VC row (and particularly if I make changes to that row as outlined above) it gets bigger.

    I’ve used exactly the same settings that worked to remove the gap on my own site, https://www.timhenselphotography.com, but it doesn’t seem to work.

    I’ll create a login for you and post below in a private comment.

    Thanks in advance!

    Tim


    Tim Hensel
    Participant
    This reply has been marked as private.
    Andy
    Andy
    Keymaster

    Hi Tim,

    I’ve had to add a bit of Custom CSS. It appears VC have changed which element they place any custom CSS on and this was preventing the 0 value you entered from working with the auto top padding that’s added when Header Float is enabled.

    i’ll resolve this for the next version.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.