Home / Forums / DynamiX Support / modify "read more"

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts

  • anne-charlotte
    Participant

    Hi,

    I have a problem translating the “read more” in my blog. I translated the entire theme but I still have “read more”. In which file can I modify it please ?

    thanks for your help.


    Tom ( Support)
    Keymaster

    Hi,

    Which translation plugin are you using? Make sure when searching for the read more words that you select the lower case option so it searches everything. Have you translated your WordPress install correctly too?

    Heres a little more information if you are a bit stuck…
    You will need to install Codestyling Localization plugin and change the WP install language to your chosen language if you haven’t already.

    More information here. After you have done this, please read the DynamiX documentation for more information on translation here.

    Once Codestyling is installed, you can then translate your words manually if needs be. Find the theme on Codestyling > Added a new language > Scan it > Created a .mo file > Edit and search for the translation > Translated Read more > Generated the .mo file again and viewed the site.


    anne-charlotte
    Participant

    My wordpress is in french and I tried with codestyling localization but it doesn’t translate it.

    Thank you


    Tom ( Support)
    Keymaster

    If you are still having issues, please set your reply to private and provide your URL/login details so I can take a further look for you.


    anne-charlotte
    Participant
    This reply has been marked as private.

    Tom ( Support)
    Keymaster

    Hi,

    I successfuly changed the name of the Read more -> link but found that as you previously had a cache plugin installed, the site was still caching. I had to re-activate it, reset the cache and the change appeared.

    Hope this helps.

    Kind regards,
    Tom


    anne-charlotte
    Participant

    Ok, I thought that inactivate the plugin would inactivate its cache too.

    Thank you for your quick support 🙂


    Tom ( Support)
    Keymaster

    We thought this too until a lot of people have been experiencing this, those plugins make more hassle than good.

    If you are happy with the theme, please take a second to rate the theme 5 stars here.

    Much appreciated 🙂


    anne-charlotte
    Participant

    Sure, I’m going to rate it now 🙂


    Tom ( Support)
    Keymaster

    Thats great, thank you 🙂


    Martin
    Participant

    Hi Tom!

    I seem to be having the same problem. The “read me” text (or any other changes I make to the nb.NO file) does not appear in front end. When I look in my Dynamix/language folder it seems the .mo file is not there. And I have made sure to hit “generate MO file”, I have tried changing the access of the language folder to 777, and changed the wp-config.php file to the corresponding nb.NO.

    I have also tried deactivating all plugins, and I have no cache plugin installed.

    I have set up several websites with Dynamix (loving it btw), but only for a few of them have I been able to get codestyling localization to work, and I cannot figure out why.

    Would you mind having a look into it? For instance with http://vhkiro.no/blogg/ ?


    Tom ( Support)
    Keymaster

    Hi Martin,

    Make sure when searching for the read more words that you select the lower case option so it searches everything. Have you translated your WordPress install correctly too?

    Heres a little more information if you are a bit stuck…
    You will need to install Codestyling Localization plugin and change the WP install language to your chosen language if you haven’t already.

    More information here. After you have done this, please read the DynamiX documentation for more information on translation here.

    Once Codestyling is installed, you can then translate your words manually if needs be. Find the theme on Codestyling > Added a new language > Scan it > Created a .mo file > Edit and search for the translation > Translated Read more > Generated the .mo file again and viewed the site.

    Kind regards,
    Tom


    Martin
    Participant

    Hi Tom! Thanks for your reply.

    Here is what I have done so far:

    1. WordPress updated and install language Norwegian (my chosen language)
    2. Codestyling localization plugin downloaded and installed.
    3. From tools -> localisation, WordPress has Norwegian installed, Dynamix has Norwegian installed.
    4. Under Dynamix, .po file scanned.
    5. Under Dynamix, opening file and editing translation for “read more” (lower case option selected)
    6. Setting database language folder to 777.
    7. Set wp-config.php to call for nb_NO
    6. Generating .mo file from within Codestyling Localization.

    No changes to front end. When I check the Dynamix/languages folder in my database, neither the .po nor the .mo file is there.

    I tried manually uploading .mo and .po files from another website to the Dynamix/languages folder and that sorted it out. And all of a sudden the changes I make when editing in Codestyling Localization appears in front end after generating .mo file.

    From this I conclude that the initial problem has to do with the .mo and the .po files not excisting in the languages folder in the first place, and for some reason adding and generating them in Codestyling Localization does not write them to the folder.

    Any idea what could still be the problem? I have the same issue on several sites, and I would rather fix it than having to upload the .mo and .po files manually.


    Tom ( Support)
    Keymaster

    Hi Martin,

    Please set your reply to private and provide your URL/login and FTP details so I can take a further look for you.


    Martin
    Participant
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.