Home / Forums / DynamiX Support / mp4 videos in Gallery Slide Set not working with jw player and lightbox

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts

  • Kevin
    Participant

    Andy,

    We are unable to get videos on our server to play correctly in the Gallery Slide Sets with lightbox.  We have tried using .mp4 and .m4v videos with the H.264 video codec. In fact, the mp4 demo video that comes with the jwplayer download will not play correctly in its native state (not flash). Can we play mp4 videos natively without using the /player.swf?flashvars= fallback?

    Thanks!

    Andy
    Andy
    Keymaster

    Hi Kevin,

    You will need to use jwplayer to play mp4 etc. If you take a look at using jwplayer with lightbox you have to add a few variables on the end but it can be done. 


    Michael Tchong
    Participant

    Video is not working for me either. I think you need a more detailed video tutorial to show how it works for you.

    For example, I noticed that your source file contains the following statement:

    ='text/javascript' src='http://dynamix.creativeworkz.co.uk/wp-content/uploads/2011/03/jwplayer.js?ver=3.3'>

    Yet, you don't explicitly mention that in your video tutorial. I assume this needs to go in the header file, but since you appear to use a customized set of instructions, I notice, for example, that your theme is not versioned, I'm still figuring out where to put it.

    Andy
    Andy
    Keymaster

    Hi Michael,

    You'll need to install jwplayer – unfortunately because of licensing I can't pre-install jwplayer.

    See this page of the documentation for installing and using jw player – http://northvantage.co.uk/helpdocs/dyn/documentation.html#two


    andy rouph
    Participant

    Hi

    I have the same problem, i think ive followed the tutorial correctly but i cant get anything to show up. Basically i have an image on my home page and i want a video to go in the light box. Any ideas?

    Many thanks

    Andy
    Andy
    Keymaster

    Hi Andy,

    It's this part you need to look at 

    JW Player in Lightbox

    To play JW Player within lightboxes specify the path of your JW Player flash file. e.g.

    /wp-content/uploads/2011/03/player.swf then add the video path using the flashvars variable. e.g.

    ?flashvars=file=/wp-content/uploads/2011/03/InsideJob-Sample.mp4

    So the full path looks similar to the following. (note! this is just an example – you'll need to modify to represent the paths to your own files).

    /wp-content/uploads/2011/03/player.swf?flashvars=file=/wp-content/uploads/2011/03/InsideJob-Sample.mp4

    Check the autoplay check option in either Gallery Slide Set or Posts → Embed Video / Timeout Options to automatically start the video.


    andy rouph
    Participant

    Ok so ive uploaded the 2 files to my media section and copied the url into my image under the video url….does this look right to you

    [imageeffect type="framelightbox" align="aligncenter" width="284" height="190" alt="" url="http://www.glowvideo.co.uk/wp-content/uploads/2012/01/front.png" videourl="/wp-content/uploads/2012/02/player.swf?flashvars=file=/wp-content/uploads/2012/01/Final-Glow-Opening-Video.mov?width=600&height=400" autoplay="yes" ]

    Still nothing comes up….it must be something im doing wrong.

    cheers

    Andy
    Andy
    Keymaster

    Hi Andy,

    I've checked it out on your site and it's working fine – it just takes a long time to load. MOV isn't the most web friendly video format – might be worth trying to convert to mp4 to save on the file size?

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.